File chromium-plugin-widevinecdm.spec of Package chromium-plugin-widevinecdm (Revision 3)
Currently displaying revision 3 , Show latest
61
1
#
2
# spec file for package chromium-plugin-widevinecdm
3
#
4
# Copyright (c) 2016 Packman Team <packman@links2linux.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.links2linux.org/
16
#
17
18
19
# To find out the real version of Widevine CDM, do something like this.
20
# d="$(mktemp -d)" && rpm2cpio *.rpm|cpio -idmD"$d" && strings "$d"/*/*/*/libwidevinecdm.so|grep -A3 widevine_cdm_version && rm -r "$d"
21
%define _chrome_version 54.0.2840.100
22
Name: chromium-plugin-widevinecdm
23
Version: 1.4.8.903
24
Release: 0
25
Summary: Chromium Widevine CDM plugin
26
License: SUSE-NonFree
27
Group: Productivity/Networking/Web/Browsers
28
Url: https://google.com/chrome
29
Source: https://dl.google.com/linux/chrome/rpm/stable/x86_64/google-chrome-stable-%{_chrome_version}-1.x86_64.rpm
30
BuildRequires: cpio
31
BuildRequires: rpm
32
Requires: chromium-browser
33
# chromium-widevinecdm-plugin was last used in openSUSE Leap 42.1.
34
Provides: chromium-widevinecdm-plugin = 22.%{version}
35
Obsoletes: chromium-widevinecdm-plugin < 22.%{version}
36
ExclusiveArch: x86_64
37
38
%description
39
Official Widevine CDM plugin for Google's FOSS browser Chromium.
40
41
%prep
42
%setup -q -c -T
43
rpm2cpio %{SOURCE0} | cpio -idmv
44
45
%build
46
# Nothing to build.
47
48
%install
49
install -Dpm 0644 opt/google/chrome/libwidevinecdm.so \
50
%{buildroot}%{_libdir}/chromium/libwidevinecdm.so
51
install -Dpm 0644 opt/google/chrome/libwidevinecdmadapter.so \
52
%{buildroot}%{_libdir}/chromium/libwidevinecdmadapter.so
53
54
%files
55
%defattr(-,root,root)
56
%dir %{_libdir}/chromium/
57
%{_libdir}/chromium/libwidevinecdm.so
58
%{_libdir}/chromium/libwidevinecdmadapter.so
59
60
%changelog
61