File rtmpdump.spec of Package rtmpdump (Revision 3e75b73146b2fd07194a388d4846e120)
Currently displaying revision 3e75b73146b2fd07194a388d4846e120 , Show latest
154
1
# norootforbuild
2
3
Name: rtmpdump
4
Version: 2.3
5
%define soname 0
6
Release: 1
7
Summary: RTMP Stream Dumper
8
Source: http://rtmpdump.mplayerhq.hu/download/rtmpdump-%{version}.tgz
9
Patch1: rtmpdump-fix_u32.patch
10
URL: http://rtmpdump.mplayerhq.hu/
11
Group: Productivity/Networking/Other
12
License: GNU General Public License version 2 (GPL v2)
13
BuildRoot: %{_tmppath}/build-%{name}-%{version}
14
BuildRequires: zlib-devel openssl-devel
15
BuildRequires: make glibc-devel gcc pkgconfig
16
Requires: librtmp%{soname} = %{version}
17
18
%description
19
A small dumper for media content streamed over the RTMP protocol (like BBC's
20
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
21
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
22
23
%package -n librtmp%{soname}
24
Summary: RTMP Stream Dumper Library
25
Group: System/Libraries
26
27
%description -n librtmp%{soname}
28
A small dumper for media content streamed over the RTMP protocol (like BBC's
29
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
30
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
31
32
%package -n rtmpsuck
33
Summary: RTMP Transparent Proxy Server
34
Group: Productivity/Networking/Other
35
Requires: librtmp%{soname} = %{version}
36
37
%description -n rtmpsuck
38
Proxy server that dumps RTMP streams.
39
40
%package -n rtmpsrv
41
Summary: RTMP Server
42
Group: Productivity/Networking/Other
43
Requires: librtmp%{soname} = %{version}
44
45
%description -n rtmpsrv
46
Server for RTMP streams.
47
48
%package -n rtmpgw
49
Summary: RTMP to HTTP Gateway
50
Group: Productivity/Networking/Other
51
Obsoletes: streams < %{version}
52
Provides: streams = %{version}
53
Requires: librtmp%{soname} = %{version}
54
55
%description -n rtmpgw
56
HTTP gateway: this is an HTTP server that accepts requests that consist of
57
rtmpdump parameters. It then connects to the specified RTMP server and returns
58
the retrieved data in the HTTP response.
59
60
%package -n librtmp-devel
61
Summary: RTMP Stream Dumping Library
62
Group: Development/Libraries/C and C++
63
%if 0%{?suse_version} >= 1030
64
Requires: libopenssl-devel
65
%else
66
Requires: openssl-devel
67
%endif
68
Requires: librtmp%{soname} = %{version}
69
70
%description -n librtmp-devel
71
A small dumper for media content streamed over the RTMP protocol (like BBC's
72
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
73
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
74
75
%debug_package
76
%prep
77
%setup -q
78
%patch1
79
80
%build
81
%__make \
82
CC="%__cc" \
83
OPT="%{optflags}" \
84
prefix="%{_prefix}" \
85
libdir="%{_libdir}" \
86
MANDIR="%{_mandir}"
87
88
%__make -C librtmp \
89
CC="%__cc" \
90
OPT="%{optflags}" \
91
prefix="%{_prefix}" \
92
libdir="%{_libdir}" \
93
MANDIR="%{_mandir}" \
94
librtmp.pc
95
96
%install
97
%__install -d "%{buildroot}%{_bindir}"
98
find . -mindepth 1 -maxdepth 1 -type f -executable -exec %__install -m0755 {} "%{buildroot}%{_bindir}/" \;
99
100
pushd librtmp
101
%__install -d "%{buildroot}%{_includedir}/librtmp" "%{buildroot}%{_libdir}" "%{buildroot}%{_libdir}/pkgconfig"
102
%__make \
103
prefix="%{buildroot}%{_prefix}" \
104
libdir="%{buildroot}%{_libdir}" \
105
INCDIR="%{buildroot}%{_includedir}/librtmp" \
106
MANDIR="%{buildroot}%{_mandir}" \
107
install
108
popd #librtmp
109
110
%post -n librtmp%{soname} -p /sbin/ldconfig
111
%postun -n librtmp%{soname} -p /sbin/ldconfig
112
113
%clean
114
%__rm -rf "%{buildroot}"
115
116
%files
117
%defattr(-,root,root)
118
%doc README ChangeLog COPYING
119
%{_bindir}/rtmpdump
120
121
%files -n librtmp%{soname}
122
%defattr(-,root,root)
123
%doc COPYING
124
%{_libdir}/librtmp.so.%{soname}
125
126
%files -n rtmpsuck
127
%defattr(-,root,root)
128
%doc README ChangeLog COPYING
129
%{_bindir}/rtmpsuck
130
131
%files -n rtmpgw
132
%defattr(-,root,root)
133
%doc README ChangeLog COPYING
134
%{_bindir}/rtmpgw
135
136
%files -n rtmpsrv
137
%defattr(-,root,root)
138
%doc README ChangeLog COPYING
139
%{_bindir}/rtmpsrv
140
141
%files -n librtmp-devel
142
%defattr(-,root,root)
143
%{_includedir}/librtmp
144
%{_libdir}/librtmp.so
145
%{_libdir}/librtmp.a
146
%{_libdir}/pkgconfig/librtmp.pc
147
%doc %{_mandir}/man3/librtmp.3%{ext_man}
148
149
# vim: set sw=3 ts=3 noet:
150
# Local Variables:
151
# mode: rpm-spec
152
# tab-width: 3
153
# End:
154