File rtmpdump.spec of Package rtmpdump (Revision 5c55e2b39d11a549cd7363a425eb13d4)
Currently displaying revision 5c55e2b39d11a549cd7363a425eb13d4 , Show latest
163
1
#
2
# spec file for package rtmpdump
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
%define soname 1
20
Name: rtmpdump
21
Version: 2.4.20151223.fa8646d
22
Release: 0
23
Summary: RTMP Stream Dumper
24
License: GPL-2.0+ and LGPL-2.1+
25
Group: Productivity/Networking/Other
26
Url: http://rtmpdump.mplayerhq.hu/
27
Source: %{name}-%{version}.tar.xz
28
Source1: baselibs.conf
29
Patch1: rtmpdump-fix_u32.patch
30
BuildRequires: libgnutls-devel
31
BuildRequires: pkgconfig
32
BuildRequires: zlib-devel
33
Requires: librtmp%{soname} = %{version}
34
BuildRoot: %{_tmppath}/%{name}-%{version}-build
35
36
%description
37
A small dumper for media content streamed over the RTMP protocol (like BBC's
38
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
39
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
40
41
%package -n librtmp%{soname}
42
Summary: RTMP Stream Dumper Library
43
Group: System/Libraries
44
License: LGPL-2.1+
45
46
%description -n librtmp%{soname}
47
A small dumper for media content streamed over the RTMP protocol (like BBC's
48
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
49
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
50
51
%package -n rtmpsuck
52
Summary: RTMP Transparent Proxy Server
53
Group: Productivity/Networking/Other
54
License: GPL-2.0+
55
56
%description -n rtmpsuck
57
Proxy server that dumps RTMP streams.
58
59
%package -n rtmpsrv
60
Summary: RTMP Server
61
Group: Productivity/Networking/Other
62
License: GPL-2.0+
63
64
%description -n rtmpsrv
65
Server for RTMP streams.
66
67
%package -n rtmpgw
68
Summary: RTMP to HTTP Gateway
69
Group: Productivity/Networking/Other
70
License: GPL-2.0+
71
72
%description -n rtmpgw
73
HTTP gateway: this is an HTTP server that accepts requests that consist of
74
rtmpdump parameters. It then connects to the specified RTMP server and returns
75
the retrieved data in the HTTP response.
76
77
%package -n librtmp-devel
78
Summary: RTMP Stream Dumping Library
79
Group: Development/Libraries/C and C++
80
Requires: librtmp%{soname} = %{version}
81
License: LGPL-2.1+
82
83
%description -n librtmp-devel
84
A small dumper for media content streamed over the RTMP protocol (like BBC's
85
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
86
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
87
88
%prep
89
%setup -q
90
%patch1
91
92
%build
93
make \
94
CC="gcc" \
95
CRYPTO="GNUTLS" \
96
OPT="%{optflags}" \
97
prefix="%{_prefix}" \
98
libdir="%{_libdir}" \
99
MANDIR="%{_mandir}"
100
101
make -C librtmp \
102
CC="gcc" \
103
CRYPTO="GNUTLS" \
104
OPT="%{optflags}" \
105
prefix="%{_prefix}" \
106
libdir="%{_libdir}" \
107
MANDIR="%{_mandir}" \
108
librtmp.pc
109
110
%install
111
install -d "%{buildroot}%{_bindir}"
112
find . -mindepth 1 -maxdepth 1 -type f -executable -exec install -m0755 {} "%{buildroot}%{_bindir}/" \;
113
114
pushd librtmp
115
install -d "%{buildroot}%{_includedir}/librtmp" "%{buildroot}%{_libdir}" "%{buildroot}%{_libdir}/pkgconfig"
116
make \
117
prefix="%{buildroot}%{_prefix}" \
118
libdir="%{buildroot}%{_libdir}" \
119
INCDIR="%{buildroot}%{_includedir}/librtmp" \
120
MANDIR="%{buildroot}%{_mandir}" \
121
install
122
popd #librtmp
123
rm %{buildroot}%{_libdir}/librtmp.a
124
125
%post -n librtmp%{soname} -p /sbin/ldconfig
126
127
%postun -n librtmp%{soname} -p /sbin/ldconfig
128
129
%files
130
%defattr(-,root,root)
131
%doc README ChangeLog COPYING
132
%{_bindir}/rtmpdump
133
134
%files -n librtmp%{soname}
135
%defattr(-,root,root)
136
%doc COPYING
137
%{_libdir}/librtmp.so.%{soname}
138
139
%files -n rtmpsuck
140
%defattr(-,root,root)
141
%doc README ChangeLog COPYING
142
%{_bindir}/rtmpsuck
143
144
%files -n rtmpgw
145
%defattr(-,root,root)
146
%doc README ChangeLog COPYING
147
%{_bindir}/rtmpgw
148
149
%files -n rtmpsrv
150
%defattr(-,root,root)
151
%doc README ChangeLog COPYING
152
%{_bindir}/rtmpsrv
153
154
%files -n librtmp-devel
155
%defattr(-,root,root)
156
%{_includedir}/librtmp
157
%{_libdir}/librtmp.so
158
%{_libdir}/pkgconfig/librtmp.pc
159
%doc %{_mandir}/man3/librtmp.3%{ext_man}
160
161
%changelog
162
163