File rtmpdump.spec of Package rtmpdump (Revision 07cba62d4c04b010972f7da55206fd50)

Currently displaying revision 07cba62d4c04b010972f7da55206fd50 , Show latest

159
 
1
# vim: set sw=3 ts=3 noet:
2
#
3
# spec file for package rtmpdump
4
#
5
6
Name:           rtmpdump
7
Version:        2.3.99.git20111114
8
Release:        0
9
License:        GPL-2.0
10
%define soname 0
11
Summary:        RTMP Stream Dumper
12
Url:            http://rtmpdump.mplayerhq.hu/
13
Group:          Productivity/Networking/Other
14
Source:         rtmpdump-%{version}.tar.bz2
15
Patch1:         rtmpdump-fix_u32.patch
16
Source99:       rtmpdump-rpmlintrc
17
BuildRequires:  gcc
18
BuildRequires:  glibc-devel
19
BuildRequires:  make
20
BuildRequires:  openssl-devel
21
BuildRequires:  pkgconfig
22
BuildRequires:  zlib-devel
23
Requires:       librtmp%{soname} = %{version}
24
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
25
26
%description
27
A small dumper for media content streamed over the RTMP protocol (like BBC's
28
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
29
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
30
31
%package -n librtmp%{soname}
32
Summary:        RTMP Stream Dumper Library
33
Group:          System/Libraries
34
35
%description -n librtmp%{soname}
36
A small dumper for media content streamed over the RTMP protocol (like BBC's
37
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
38
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
39
40
%package -n rtmpsuck
41
Summary:        RTMP Transparent Proxy Server
42
Group:          Productivity/Networking/Other
43
Requires:       librtmp%{soname} = %{version}
44
45
%description -n rtmpsuck
46
Proxy server that dumps RTMP streams.
47
48
%package -n rtmpsrv
49
Summary:        RTMP Server
50
Group:          Productivity/Networking/Other
51
Requires:       librtmp%{soname} = %{version}
52
53
%description -n rtmpsrv
54
Server for RTMP streams.
55
56
%package -n rtmpgw
57
Summary:        RTMP to HTTP Gateway
58
Group:          Productivity/Networking/Other
59
Requires:       librtmp%{soname} = %{version}
60
Obsoletes:      streams < %{version}
61
Provides:       streams = %{version}
62
63
%description -n rtmpgw
64
HTTP gateway: this is an HTTP server that accepts requests that consist of
65
rtmpdump parameters. It then connects to the specified RTMP server and returns
66
the retrieved data in the HTTP response.
67
68
%package -n librtmp-devel
69
Summary:        RTMP Stream Dumping Library
70
Group:          Development/Libraries/C and C++
71
%if 0%{?suse_version} >= 1030
72
Requires:       libopenssl-devel
73
%else
74
Requires:       openssl-devel
75
%endif
76
Requires:       librtmp%{soname} = %{version}
77
78
%description -n librtmp-devel
79
A small dumper for media content streamed over the RTMP protocol (like BBC's
80
iPlayer high quality streams). Supplying an rtmp url will result in a dumped
81
flv file, which can be played/transcoded using ffmpeg/mplayer, etc.
82
83
%prep
84
%setup -q
85
%patch1
86
87
%build
88
make \
89
     CC="gcc" \
90
     OPT="%{optflags}" \
91
     prefix="%{_prefix}" \
92
     libdir="%{_libdir}" \
93
     MANDIR="%{_mandir}"
94
95
make -C librtmp \
96
     CC="gcc" \
97
     OPT="%{optflags}" \
98
     prefix="%{_prefix}" \
99
     libdir="%{_libdir}" \
100
     MANDIR="%{_mandir}" \
101
     librtmp.pc
102
103
%install
104
install -d "%{buildroot}%{_bindir}"
105
find . -mindepth 1 -maxdepth 1 -type f -executable -exec install -m0755 {} "%{buildroot}%{_bindir}/" \;
106
107
pushd librtmp
108
install -d "%{buildroot}%{_includedir}/librtmp" "%{buildroot}%{_libdir}" "%{buildroot}%{_libdir}/pkgconfig"
109
make \
110
     prefix="%{buildroot}%{_prefix}" \
111
     libdir="%{buildroot}%{_libdir}" \
112
     INCDIR="%{buildroot}%{_includedir}/librtmp" \
113
     MANDIR="%{buildroot}%{_mandir}" \
114
     install
115
popd #librtmp
116
117
%post   -n librtmp%{soname} -p /sbin/ldconfig
118
%postun -n librtmp%{soname} -p /sbin/ldconfig
119
120
%files
121
%defattr(-,root,root)
122
%doc README ChangeLog COPYING
123
%{_bindir}/rtmpdump
124
125
%files -n librtmp%{soname}
126
%defattr(-,root,root)
127
%doc COPYING
128
%{_libdir}/librtmp.so.%{soname}
129
130
%files -n rtmpsuck
131
%defattr(-,root,root)
132
%doc README ChangeLog COPYING
133
%{_bindir}/rtmpsuck
134
135
%files -n rtmpgw
136
%defattr(-,root,root)
137
%doc README ChangeLog COPYING
138
%{_bindir}/rtmpgw
139
140
%files -n rtmpsrv
141
%defattr(-,root,root)
142
%doc README ChangeLog COPYING
143
%{_bindir}/rtmpsrv
144
145
%files -n librtmp-devel
146
%defattr(-,root,root)
147
%{_includedir}/librtmp
148
%{_libdir}/librtmp.so
149
%{_libdir}/librtmp.a
150
%{_libdir}/pkgconfig/librtmp.pc
151
%doc %{_mandir}/man3/librtmp.3%{ext_man}
152
153
# Local Variables:
154
# mode: rpm-spec
155
# tab-width: 3
156
# End:
157
158
%changelog
159