File x265.spec of Package x265 (Revision 27)
Currently displaying revision 27 , Show latest
96
1
# based on the spec file from https://build.opensuse.org/package/view_file/home:Simmphonie/libx265/
2
3
Name: x265
4
%define soname 146
5
%define libname lib%{name}
6
%define libsoname %{libname}-%{soname}
7
Version: 2.6
8
Release: 0
9
License: GPL-2.0+
10
Summary: A free h265/HEVC encoder - encoder binary
11
Url: https://bitbucket.org/multicoreware/x265/wiki/Home
12
Group: Productivity/Multimedia/Video/Editors and Convertors
13
Source0: https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
14
Patch0: arm.patch
15
Patch1: x265.pkgconfig.patch
16
BuildRequires: gcc gcc-c++
17
BuildRequires: cmake >= 2.8.8
18
BuildRequires: pkg-config
19
BuildRequires: yasm >= 1.2.0
20
BuildRoot: %{_tmppath}/%{name}-%{version}-build
21
%if 0%{?suse_version} > 1310
22
%ifarch x86_64
23
BuildRequires: libnuma-devel >= 2.0.9
24
%endif
25
%endif
26
27
%description
28
x265 is a free library for encoding next-generation H265/HEVC video
29
streams.
30
31
%package -n %{libsoname}
32
Summary: A free H265/HEVC encoder - encoder binary
33
Group: Productivity/Multimedia/Video/Editors and Convertors
34
35
%description -n %{libsoname}
36
x265 is a free library for encoding next-generation H265/HEVC video
37
streams.
38
39
%package -n %{libname}-devel
40
Summary: Libraries and include file for the %{libname} encoder
41
Group: Development/Libraries/C and C++
42
Requires: %{buildrequires}
43
Requires: %{libsoname} = %{version}
44
Provides: %{name}-devel = %{version}
45
Obsoletes: %{name}-devel < %{version}
46
47
%description -n %{libname}-devel
48
x265 is a free library for encoding next-generation H265/HEVC video
49
streams.
50
51
%prep
52
%setup -q -n %{name}_v%{version}
53
%patch0 -p1
54
%patch1 -p1
55
56
sed -i -e "s/0.0/%{soname}.0/g" source/cmake/version.cmake
57
58
59
%build
60
%if 0%{?suse_version} < 1330
61
cd source
62
%else
63
%define __builddir ./source/build
64
%define __sourcedir ./source
65
%endif
66
%cmake -DENABLE_TESTS=OFF
67
make %{?_smp_mflags}
68
69
%install
70
%if 0%{?suse_version} < 1330
71
cd source
72
%endif
73
%cmake_install
74
rm -f %{buildroot}%{_libdir}/%{libname}.a
75
echo "%{libname}-%{soname}" > %{_sourcedir}/baselibs.conf
76
77
%post -n %{libsoname} -p /sbin/ldconfig
78
%postun -n %{libsoname} -p /sbin/ldconfig
79
80
%files -n %{libsoname}
81
%defattr(0644,root,root)
82
%{_libdir}/%{libname}.so.%{soname}*
83
84
%files
85
%defattr(0755,root,root)
86
%{_bindir}/%{name}
87
88
%files -n %{libname}-devel
89
%defattr(0644,root,root)
90
%{_includedir}/%{name}.h
91
%{_includedir}/%{name}_config.h
92
%{_libdir}/pkgconfig/%{name}.pc
93
%{_libdir}/%{libname}.so
94
95
%changelog
96