File x265.spec of Package x265 (Revision 28)
Currently displaying revision 28 , Show latest
99
1
# based on the spec file from https://build.opensuse.org/package/view_file/home:Simmphonie/libx265/
2
3
Name: x265
4
%define soname 151
5
%define libname lib%{name}
6
%define libsoname %{libname}-%{soname}
7
Version: 2.7
8
Release: 0
9
License: GPL-2.0+
10
Summary: A free h265/HEVC encoder - encoder binary
11
Url: https://bitbucket.org/multicoreware/x265/wiki/Home
12
Group: Productivity/Multimedia/Video/Editors and Convertors
13
Source0: https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
14
Patch0: arm.patch
15
Patch1: x265.pkgconfig.patch
16
BuildRequires: gcc
17
BuildRequires: gcc-c++
18
BuildRequires: cmake >= 2.8.8
19
BuildRequires: pkg-config
20
%if 0%{?suse_version} >=1500
21
BuildRequires: nasm >= 2.13
22
%endif
23
%if 0%{?suse_version} > 1310
24
%ifarch x86_64
25
BuildRequires: libnuma-devel >= 2.0.9
26
%endif
27
%endif
28
BuildRoot: %{_tmppath}/%{name}-%{version}-build
29
30
%description
31
x265 is a free library for encoding next-generation H265/HEVC video
32
streams.
33
34
%package -n %{libsoname}
35
Summary: A free H265/HEVC encoder - encoder binary
36
Group: Productivity/Multimedia/Video/Editors and Convertors
37
38
%description -n %{libsoname}
39
x265 is a free library for encoding next-generation H265/HEVC video
40
streams.
41
42
%package -n %{libname}-devel
43
Summary: Libraries and include file for the %{libname} encoder
44
Group: Development/Libraries/C and C++
45
Requires: %{buildrequires}
46
Requires: %{libsoname} = %{version}
47
Provides: %{name}-devel = %{version}
48
Obsoletes: %{name}-devel < %{version}
49
50
%description -n %{libname}-devel
51
x265 is a free library for encoding next-generation H265/HEVC video
52
streams.
53
54
%prep
55
%setup -q -n %{name}_%{version}
56
%patch0 -p1
57
%patch1 -p1
58
59
sed -i -e "s/0.0/%{soname}.0/g" source/cmake/version.cmake
60
61
62
%build
63
%if 0%{?suse_version} < 1330
64
cd source
65
%else
66
%define __builddir ./source/build
67
%define __sourcedir ./source
68
%endif
69
%cmake -DENABLE_TESTS=OFF
70
make %{?_smp_mflags}
71
72
%install
73
%if 0%{?suse_version} < 1330
74
cd source
75
%endif
76
%cmake_install
77
rm -f %{buildroot}%{_libdir}/%{libname}.a
78
echo "%{libname}-%{soname}" > %{_sourcedir}/baselibs.conf
79
80
%post -n %{libsoname} -p /sbin/ldconfig
81
%postun -n %{libsoname} -p /sbin/ldconfig
82
83
%files -n %{libsoname}
84
%defattr(0644,root,root)
85
%{_libdir}/%{libname}.so.%{soname}*
86
87
%files
88
%defattr(0755,root,root)
89
%{_bindir}/%{name}
90
91
%files -n %{libname}-devel
92
%defattr(0644,root,root)
93
%{_includedir}/%{name}.h
94
%{_includedir}/%{name}_config.h
95
%{_libdir}/pkgconfig/%{name}.pc
96
%{_libdir}/%{libname}.so
97
98
%changelog
99