File x265.spec of Package x265 (Revision 29)
Currently displaying revision 29 , Show latest
97
1
# based on the spec file from https://build.opensuse.org/package/view_file/home:Simmphonie/libx265/
2
3
Name: x265
4
%define soname 151
5
%define libname lib%{name}
6
%define libsoname %{libname}-%{soname}
7
Version: 2.7
8
Release: 0
9
License: GPL-2.0+
10
Summary: A free h265/HEVC encoder - encoder binary
11
Url: https://bitbucket.org/multicoreware/x265/wiki/Home
12
Group: Productivity/Multimedia/Video/Editors and Convertors
13
Source0: https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
14
Patch0: arm.patch
15
Patch1: x265.pkgconfig.patch
16
BuildRequires: gcc
17
BuildRequires: gcc-c++
18
BuildRequires: cmake >= 2.8.8
19
BuildRequires: pkg-config
20
BuildRequires: nasm >= 2.13
21
%if 0%{?suse_version} > 1310
22
%ifarch x86_64
23
BuildRequires: libnuma-devel >= 2.0.9
24
%endif
25
%endif
26
BuildRoot: %{_tmppath}/%{name}-%{version}-build
27
28
%description
29
x265 is a free library for encoding next-generation H265/HEVC video
30
streams.
31
32
%package -n %{libsoname}
33
Summary: A free H265/HEVC encoder - encoder binary
34
Group: Productivity/Multimedia/Video/Editors and Convertors
35
36
%description -n %{libsoname}
37
x265 is a free library for encoding next-generation H265/HEVC video
38
streams.
39
40
%package -n %{libname}-devel
41
Summary: Libraries and include file for the %{libname} encoder
42
Group: Development/Libraries/C and C++
43
Requires: %{buildrequires}
44
Requires: %{libsoname} = %{version}
45
Provides: %{name}-devel = %{version}
46
Obsoletes: %{name}-devel < %{version}
47
48
%description -n %{libname}-devel
49
x265 is a free library for encoding next-generation H265/HEVC video
50
streams.
51
52
%prep
53
%setup -q -n %{name}_%{version}
54
%patch0 -p1
55
%patch1 -p1
56
57
sed -i -e "s/0.0/%{soname}.0/g" source/cmake/version.cmake
58
59
60
%build
61
%if 0%{?suse_version} < 1330
62
cd source
63
%else
64
%define __builddir ./source/build
65
%define __sourcedir ./source
66
%endif
67
%cmake -DENABLE_TESTS=OFF
68
make %{?_smp_mflags}
69
70
%install
71
%if 0%{?suse_version} < 1330
72
cd source
73
%endif
74
%cmake_install
75
rm -f %{buildroot}%{_libdir}/%{libname}.a
76
echo "%{libname}-%{soname}" > %{_sourcedir}/baselibs.conf
77
78
%post -n %{libsoname} -p /sbin/ldconfig
79
%postun -n %{libsoname} -p /sbin/ldconfig
80
81
%files -n %{libsoname}
82
%defattr(0644,root,root)
83
%{_libdir}/%{libname}.so.%{soname}*
84
85
%files
86
%defattr(0755,root,root)
87
%{_bindir}/%{name}
88
89
%files -n %{libname}-devel
90
%defattr(0644,root,root)
91
%{_includedir}/%{name}.h
92
%{_includedir}/%{name}_config.h
93
%{_libdir}/pkgconfig/%{name}.pc
94
%{_libdir}/%{libname}.so
95
96
%changelog
97