File x265.spec of Package x265 (Revision 30)

Currently displaying revision 30 , Show latest

95
 
1
# based on the spec file from https://build.opensuse.org/package/view_file/home:Simmphonie/libx265/
2
3
Name:           x265
4
%define soname  165
5
%define libname lib%{name}
6
%define libsoname %{libname}-%{soname}
7
Version:        2.9
8
Release:        0
9
License:        GPL-2.0+
10
Summary:        A free h265/HEVC encoder - encoder binary
11
Url:            https://bitbucket.org/multicoreware/x265/wiki/Home
12
Group:          Productivity/Multimedia/Video/Editors and Convertors
13
Source0:        https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
14
Patch0:         arm.patch
15
Patch1:         x265.pkgconfig.patch
16
Patch2:         x265-fix_enable512.patch
17
BuildRequires:  gcc
18
BuildRequires:  gcc-c++
19
BuildRequires:  cmake >= 2.8.8
20
BuildRequires:  pkg-config
21
BuildRequires:  nasm >= 2.13
22
%ifarch x86_64
23
BuildRequires:  libnuma-devel >= 2.0.9
24
%endif
25
26
%description
27
x265 is a free library for encoding next-generation H265/HEVC video
28
streams.
29
30
%package -n %{libsoname}
31
Summary:        A free H265/HEVC encoder - encoder binary
32
Group:          Productivity/Multimedia/Video/Editors and Convertors
33
34
%description -n %{libsoname}
35
x265 is a free library for encoding next-generation H265/HEVC video
36
streams.
37
38
%package -n %{libname}-devel
39
Summary:        Libraries and include file for the %{libname} encoder
40
Group:          Development/Libraries/C and C++
41
Requires:       %{buildrequires}
42
Requires:       %{libsoname} = %{version}
43
Provides:       %{name}-devel = %{version}
44
Obsoletes:      %{name}-devel < %{version}
45
46
%description -n %{libname}-devel
47
x265 is a free library for encoding next-generation H265/HEVC video
48
streams.
49
50
%prep
51
%setup -q -n %{name}_%{version}
52
%patch0 -p1
53
%patch1 -p1
54
%patch2 -p1
55
56
sed -i -e "s/0.0/%{soname}.0/g" source/cmake/version.cmake
57
58
59
%build
60
%if 0%{?suse_version} < 1500
61
cd source
62
%else
63
%define __builddir ./source/build
64
%define __sourcedir ./source
65
%endif
66
%cmake -DENABLE_TESTS=OFF
67
make %{?_smp_mflags}
68
69
%install
70
%if 0%{?suse_version} < 1500
71
cd source
72
%endif
73
%cmake_install
74
rm -f %{buildroot}%{_libdir}/%{libname}.a
75
echo "%{libname}-%{soname}" > %{_sourcedir}/baselibs.conf
76
77
%post -n %{libsoname} -p /sbin/ldconfig
78
%postun -n %{libsoname} -p /sbin/ldconfig
79
80
%files -n %{libsoname}
81
%{_libdir}/%{libname}.so.%{soname}*
82
83
%files
84
%{_bindir}/%{name}
85
86
%files -n %{libname}-devel
87
%license COPYING
88
%doc readme.rst
89
%{_includedir}/%{name}.h
90
%{_includedir}/%{name}_config.h
91
%{_libdir}/pkgconfig/%{name}.pc
92
%{_libdir}/%{libname}.so
93
94
%changelog
95