File x265.spec of Package x265 (Revision 32)
Currently displaying revision 32 , Show latest
133
1
# based on the spec file from https://build.opensuse.org/package/view_file/home:Simmphonie/libx265/
2
3
Name: x265
4
%define soname 176
5
%define libname lib%{name}
6
%define libsoname %{libname}-%{soname}
7
Version: 3.1.1
8
Release: 0
9
License: GPL-2.0+
10
Summary: A free h265/HEVC encoder - encoder binary
11
Url: https://bitbucket.org/multicoreware/x265/wiki/Home
12
Group: Productivity/Multimedia/Video/Editors and Convertors
13
Source0: https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
14
Patch0: arm.patch
15
Patch1: x265.pkgconfig.patch
16
Patch2: x265-fix_enable512.patch
17
BuildRequires: gcc
18
BuildRequires: gcc-c++
19
BuildRequires: cmake >= 2.8.8
20
BuildRequires: pkg-config
21
BuildRequires: nasm >= 2.13
22
%ifarch x86_64
23
BuildRequires: libnuma-devel >= 2.0.9
24
%endif
25
26
%description
27
x265 is a free library for encoding next-generation H265/HEVC video
28
streams.
29
30
%package -n %{libsoname}
31
Summary: A free H265/HEVC encoder - encoder binary
32
Group: Productivity/Multimedia/Video/Editors and Convertors
33
34
%description -n %{libsoname}
35
x265 is a free library for encoding next-generation H265/HEVC video
36
streams.
37
38
%package -n %{libname}-devel
39
Summary: Libraries and include file for the %{libname} encoder
40
Group: Development/Libraries/C and C++
41
Requires: %{buildrequires}
42
Requires: %{libsoname} = %{version}
43
Provides: %{name}-devel = %{version}
44
Obsoletes: %{name}-devel < %{version}
45
46
%description -n %{libname}-devel
47
x265 is a free library for encoding next-generation H265/HEVC video
48
streams.
49
50
%prep
51
%setup -q -n %{name}_%{version}
52
%patch0 -p1
53
%patch1 -p1
54
%patch2 -p1
55
56
sed -i -e "s/0.0/%{soname}.0/g" source/cmake/version.cmake
57
58
59
%build
60
SOURCE_DIR="$PWD"/source
61
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON"
62
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
63
64
%if 0%{?suse_version} >= 1500
65
%define __sourcedir ./source
66
67
# Build 10bit depth version of the library
68
%define __builddir ./source/build-10bit
69
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
70
%ifarch i586
71
-DENABLE_ASSEMBLY=OFF
72
%endif
73
74
make %{?_smp_mflags}
75
cd ../..
76
77
# Build 12bit depth version of the library
78
%define __builddir ./source/build-12bit
79
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
80
%ifarch i586
81
-DENABLE_ASSEMBLY=OFF
82
%endif
83
84
make %{?_smp_mflags}
85
cd ../..
86
87
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
88
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
89
90
# Build general version of the library linking in the 10/12bit depth versions
91
%define __builddir ./source/build
92
%cmake -DENABLE_TESTS=OFF \
93
-DENABLE_PIC=ON \
94
-DENABLE_CLI=ON \
95
-DLINKED_10BIT=ON \
96
-DLINKED_12BIT=ON \
97
-DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
98
-DEXTRA_LIB="x265_main10.a;x265_main12.a"
99
100
%else
101
cd source
102
%cmake $COMMON_FLAGS
103
%endif
104
make %{?_smp_mflags}
105
cd ../../
106
107
%install
108
%if 0%{?suse_version} < 1500
109
cd source
110
%endif
111
%cmake_install
112
rm -f %{buildroot}%{_libdir}/%{libname}.a
113
echo "%{libname}-%{soname}" > %{_sourcedir}/baselibs.conf
114
115
%post -n %{libsoname} -p /sbin/ldconfig
116
%postun -n %{libsoname} -p /sbin/ldconfig
117
118
%files -n %{libsoname}
119
%{_libdir}/%{libname}.so.%{soname}*
120
121
%files
122
%{_bindir}/%{name}
123
124
%files -n %{libname}-devel
125
%license COPYING
126
%doc readme.rst
127
%{_includedir}/%{name}.h
128
%{_includedir}/%{name}_config.h
129
%{_libdir}/pkgconfig/%{name}.pc
130
%{_libdir}/%{libname}.so
131
132
%changelog
133