File x265.spec of Package x265 (Revision 34)

Currently displaying revision 34 , Show latest

149
 
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2019 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define soname  179
21
%define libname lib%{name}
22
%define libsoname %{libname}-%{soname}
23
Name:           x265
24
Version:        3.2
25
Release:        0
26
Summary:        A free h265/HEVC encoder - encoder binary
27
License:        GPL-2.0-or-later
28
Group:          Productivity/Multimedia/Video/Editors and Convertors
29
URL:            https://bitbucket.org/multicoreware/x265/wiki/Home
30
Source0:        https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
31
Patch0:         arm.patch
32
Patch1:         x265.pkgconfig.patch
33
Patch2:         x265-fix_enable512.patch
34
BuildRequires:  cmake >= 2.8.8
35
BuildRequires:  gcc-c++
36
BuildRequires:  nasm >= 2.13
37
BuildRequires:  pkgconfig
38
%ifarch x86_64
39
BuildRequires:  libnuma-devel >= 2.0.9
40
%endif
41
42
%description
43
x265 is a free library for encoding next-generation H265/HEVC video
44
streams.
45
46
%package -n %{libsoname}
47
Summary:        A free H265/HEVC encoder - encoder binary
48
Group:          Productivity/Multimedia/Video/Editors and Convertors
49
50
%description -n %{libsoname}
51
x265 is a free library for encoding next-generation H265/HEVC video
52
streams.
53
54
%package -n %{libname}-devel
55
Summary:        Libraries and include file for the %{libname} encoder
56
Group:          Development/Libraries/C and C++
57
Requires:       %{buildrequires}
58
Requires:       %{libsoname} = %{version}
59
Provides:       %{name}-devel = %{version}
60
Obsoletes:      %{name}-devel < %{version}
61
62
%description -n %{libname}-devel
63
x265 is a free library for encoding next-generation H265/HEVC video
64
streams.
65
66
%prep
67
%setup -q -n %{name}_%{version}
68
%patch0 -p1
69
%patch1 -p1
70
%patch2 -p1
71
72
sed -i -e "s/0.0/%{soname}.0/g" source/cmake/version.cmake
73
74
75
%build
76
SOURCE_DIR="$PWD"/source
77
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON"
78
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
79
80
%if 0%{?suse_version} >= 1500
81
%define __sourcedir ./source
82
83
# Build 10bit depth version of the library
84
%define __builddir ./source/build-10bit
85
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
86
%ifarch i586
87
      -DENABLE_ASSEMBLY=OFF
88
%endif
89
90
make %{?_smp_mflags}
91
cd ../..
92
93
# Build 12bit depth version of the library
94
%define __builddir ./source/build-12bit
95
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
96
%ifarch i586
97
      -DENABLE_ASSEMBLY=OFF
98
%endif
99
100
make %{?_smp_mflags}
101
cd ../..
102
103
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
104
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
105
106
# Build general version of the library linking in the 10/12bit depth versions
107
%define __builddir ./source/build
108
%cmake -DENABLE_TESTS=OFF \
109
       -DENABLE_PIC=ON \
110
       -DENABLE_CLI=ON \
111
       -DLINKED_10BIT=ON \
112
       -DLINKED_12BIT=ON \
113
       -DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
114
       -DEXTRA_LIB="x265_main10.a;x265_main12.a"
115
116
%else
117
cd source
118
%cmake $COMMON_FLAGS
119
%endif
120
make %{?_smp_mflags}
121
cd ../../
122
123
%install
124
%if 0%{?suse_version} < 1500
125
cd source
126
%endif
127
%cmake_install
128
rm -f %{buildroot}%{_libdir}/%{libname}.a
129
echo "%{libname}-%{soname}" > %{_sourcedir}/baselibs.conf
130
131
%post -n %{libsoname} -p /sbin/ldconfig
132
%postun -n %{libsoname} -p /sbin/ldconfig
133
134
%files -n %{libsoname}
135
%{_libdir}/%{libname}.so.%{soname}*
136
137
%files
138
%{_bindir}/%{name}
139
140
%files -n %{libname}-devel
141
%license COPYING
142
%doc readme.rst
143
%{_includedir}/%{name}.h
144
%{_includedir}/%{name}_config.h
145
%{_libdir}/pkgconfig/%{name}.pc
146
%{_libdir}/%{libname}.so
147
148
%changelog
149