File x265.spec of Package x265 (Revision 38)
Currently displaying revision 38 , Show latest
148
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2020 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define sover 188
21
%define libname lib%{name}
22
%define libsoname %{libname}-%{sover}
23
Name: x265
24
Version: 3.3
25
Release: 0
26
Summary: A free h265/HEVC encoder - encoder binary
27
License: GPL-2.0-or-later
28
Group: Productivity/Multimedia/Video/Editors and Convertors
29
URL: https://bitbucket.org/multicoreware/x265/wiki/Home
30
Source0: https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
31
Patch0: arm.patch
32
Patch1: x265.pkgconfig.patch
33
Patch2: x265-fix_enable512.patch
34
BuildRequires: cmake >= 2.8.8
35
BuildRequires: gcc-c++
36
BuildRequires: nasm >= 2.13
37
BuildRequires: pkgconfig
38
%ifarch x86_64
39
BuildRequires: libnuma-devel >= 2.0.9
40
%endif
41
42
%description
43
x265 is a free library for encoding next-generation H265/HEVC video
44
streams.
45
46
%package -n %{libsoname}
47
Summary: A free H265/HEVC encoder - encoder binary
48
Group: Productivity/Multimedia/Video/Editors and Convertors
49
50
%description -n %{libsoname}
51
x265 is a free library for encoding next-generation H265/HEVC video
52
streams.
53
54
%package -n %{libname}-devel
55
Summary: Libraries and include file for the %{libname} encoder
56
Group: Development/Libraries/C and C++
57
Requires: %{libsoname} = %{version}-%{release}
58
Provides: %{name}-devel = %{version}
59
Obsoletes: %{name}-devel < %{version}
60
61
%description -n %{libname}-devel
62
x265 is a free library for encoding next-generation H265/HEVC video
63
streams.
64
65
%prep
66
%setup -q -n %{name}_%{version}
67
%patch0 -p1
68
%patch1 -p1
69
%patch2 -p1
70
71
sed -i -e "s/0.0/%{sover}.0/g" source/cmake/version.cmake
72
73
74
%build
75
SOURCE_DIR="$PWD"/source
76
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON"
77
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
78
79
%if 0%{?suse_version} >= 1500
80
%define __sourcedir ./source
81
82
# Build 10bit depth version of the library
83
%define __builddir ./source/build-10bit
84
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
85
%ifarch i586
86
-DENABLE_ASSEMBLY=OFF
87
%endif
88
89
make %{?_smp_mflags}
90
cd ../..
91
92
# Build 12bit depth version of the library
93
%define __builddir ./source/build-12bit
94
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
95
%ifarch i586
96
-DENABLE_ASSEMBLY=OFF
97
%endif
98
99
make %{?_smp_mflags}
100
cd ../..
101
102
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
103
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
104
105
# Build general version of the library linking in the 10/12bit depth versions
106
%define __builddir ./source/build
107
%cmake -DENABLE_TESTS=OFF \
108
-DENABLE_PIC=ON \
109
-DENABLE_CLI=ON \
110
-DLINKED_10BIT=ON \
111
-DLINKED_12BIT=ON \
112
-DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
113
-DEXTRA_LIB="x265_main10.a;x265_main12.a"
114
115
%else
116
cd source
117
%cmake $COMMON_FLAGS
118
%endif
119
make %{?_smp_mflags}
120
cd ../../
121
122
%install
123
%if 0%{?suse_version} < 1500
124
cd source
125
%endif
126
%cmake_install
127
rm -f %{buildroot}%{_libdir}/%{libname}.a
128
echo "%{libname}-%{sover}" > %{_sourcedir}/baselibs.conf
129
130
%post -n %{libsoname} -p /sbin/ldconfig
131
%postun -n %{libsoname} -p /sbin/ldconfig
132
133
%files -n %{libsoname}
134
%{_libdir}/%{libname}.so.%{sover}*
135
136
%files
137
%{_bindir}/%{name}
138
139
%files -n %{libname}-devel
140
%license COPYING
141
%doc readme.rst
142
%{_includedir}/%{name}.h
143
%{_includedir}/%{name}_config.h
144
%{_libdir}/pkgconfig/%{name}.pc
145
%{_libdir}/%{libname}.so
146
147
%changelog
148