File x265.spec of Package x265 (Revision 39)
Currently displaying revision 39 , Show latest
147
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2020 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define sover 192
21
%define libname lib%{name}
22
%define libsoname %{libname}-%{sover}
23
Name: x265
24
Version: 3.4
25
Release: 0
26
Summary: A free h265/HEVC encoder - encoder binary
27
License: GPL-2.0-or-later
28
Group: Productivity/Multimedia/Video/Editors and Convertors
29
URL: https://bitbucket.org/multicoreware/x265/wiki/Home
30
Source0: https://bitbucket.org/multicoreware/x265/downloads/%{name}_%{version}.tar.gz
31
Patch0: arm.patch
32
Patch1: x265.pkgconfig.patch
33
Patch2: x265-fix_enable512.patch
34
BuildRequires: cmake >= 2.8.8
35
BuildRequires: gcc-c++
36
BuildRequires: nasm >= 2.13
37
BuildRequires: pkgconfig
38
%ifarch x86_64
39
BuildRequires: libnuma-devel >= 2.0.9
40
%endif
41
42
%description
43
x265 is a free library for encoding next-generation H265/HEVC video
44
streams.
45
46
%package -n %{libsoname}
47
Summary: A free H265/HEVC encoder - encoder binary
48
Group: Productivity/Multimedia/Video/Editors and Convertors
49
50
%description -n %{libsoname}
51
x265 is a free library for encoding next-generation H265/HEVC video
52
streams.
53
54
%package -n %{libname}-devel
55
Summary: Libraries and include file for the %{libname} encoder
56
Group: Development/Libraries/C and C++
57
Requires: %{libsoname} = %{version}-%{release}
58
Provides: %{name}-devel = %{version}
59
Obsoletes: %{name}-devel < %{version}
60
61
%description -n %{libname}-devel
62
x265 is a free library for encoding next-generation H265/HEVC video
63
streams.
64
65
%prep
66
%setup -q -n %{name}_%{version}
67
%patch0 -p1
68
%patch1 -p1
69
%patch2 -p1
70
sed -i -e "s/0.0/%{sover}.0/g" source/cmake/version.cmake
71
72
73
%build
74
SOURCE_DIR="$PWD"/source
75
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON"
76
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
77
78
%if 0%{?suse_version} >= 1500
79
%define __sourcedir ./source
80
81
# Build 10bit depth version of the library
82
%define __builddir ./source/build-10bit
83
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
84
%ifarch i586
85
-DENABLE_ASSEMBLY=OFF
86
%endif
87
88
make %{?_smp_mflags}
89
cd ../..
90
91
# Build 12bit depth version of the library
92
%define __builddir ./source/build-12bit
93
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
94
%ifarch i586
95
-DENABLE_ASSEMBLY=OFF
96
%endif
97
98
make %{?_smp_mflags}
99
cd ../..
100
101
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
102
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
103
104
# Build general version of the library linking in the 10/12bit depth versions
105
%define __builddir ./source/build
106
%cmake -DENABLE_TESTS=OFF \
107
-DENABLE_PIC=ON \
108
-DENABLE_CLI=ON \
109
-DLINKED_10BIT=ON \
110
-DLINKED_12BIT=ON \
111
-DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
112
-DEXTRA_LIB="x265_main10.a;x265_main12.a"
113
114
%else
115
cd source
116
%cmake $COMMON_FLAGS
117
%endif
118
make %{?_smp_mflags}
119
cd ../../
120
121
%install
122
%if 0%{?suse_version} < 1500
123
cd source
124
%endif
125
%cmake_install
126
rm -f %{buildroot}%{_libdir}/%{libname}.a
127
echo "%{libname}-%{sover}" > %{_sourcedir}/baselibs.conf
128
129
%post -n %{libsoname} -p /sbin/ldconfig
130
%postun -n %{libsoname} -p /sbin/ldconfig
131
132
%files -n %{libsoname}
133
%{_libdir}/%{libname}.so.%{sover}*
134
135
%files
136
%{_bindir}/%{name}
137
138
%files -n %{libname}-devel
139
%license COPYING
140
%doc readme.rst
141
%{_includedir}/%{name}.h
142
%{_includedir}/%{name}_config.h
143
%{_libdir}/pkgconfig/%{name}.pc
144
%{_libdir}/%{libname}.so
145
146
%changelog
147