File x265.spec of Package x265 (Revision 40)

Currently displaying revision 40 , Show latest

173
 
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2021 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define sover   199
21
%define libname lib%{name}
22
%define libsoname %{libname}-%{sover}
23
%define uver    3_5
24
Name:           x265
25
Version:        3.5
26
Release:        0
27
Summary:        A free h265/HEVC encoder - encoder binary
28
License:        GPL-2.0-or-later
29
Group:          Productivity/Multimedia/Video/Editors and Convertors
30
URL:            https://bitbucket.org/multicoreware/x265_git
31
Source0:        https://bitbucket.org/multicoreware/x265_git/downloads/%{name}_%{version}.tar.gz
32
Patch0:         arm.patch
33
Patch1:         x265.pkgconfig.patch
34
Patch2:         x265-fix_enable512.patch
35
BuildRequires:  cmake >= 2.8.8
36
BuildRequires:  gcc-c++
37
BuildRequires:  nasm >= 2.13
38
BuildRequires:  pkgconfig
39
%ifarch x86_64
40
BuildRequires:  libnuma-devel >= 2.0.9
41
%endif
42
43
%description
44
x265 is a free library for encoding next-generation H265/HEVC video
45
streams.
46
47
%package -n %{libsoname}
48
Summary:        A free H265/HEVC encoder - encoder binary
49
Group:          Productivity/Multimedia/Video/Editors and Convertors
50
51
%description -n %{libsoname}
52
x265 is a free library for encoding next-generation H265/HEVC video
53
streams.
54
55
%package -n libhdr10plus-%{uver}
56
Summary:        A free HDR10+ library
57
Group:          Productivity/Multimedia/Video/Editors and Convertors
58
59
%description -n libhdr10plus-%{uver}
60
A free library supporting HDR10+.
61
62
%package -n %{libname}-devel
63
Summary:        Libraries and include file for the %{libname} encoder
64
Group:          Development/Libraries/C and C++
65
Requires:       %{libsoname} = %{version}-%{release}
66
Requires:       libhdr10plus-%{uver} = %{version}-%{release}
67
Provides:       %{name}-devel = %{version}
68
Obsoletes:      %{name}-devel < %{version}
69
70
%description -n %{libname}-devel
71
x265 is a free library for encoding next-generation H265/HEVC video
72
streams.
73
74
%prep
75
%setup -q -n %{name}_%{version}
76
%patch0 -p1
77
%patch1 -p1
78
%patch2 -p1
79
# set the version by hand
80
sed -i "/^include(Version)/d" source/CMakeLists.txt
81
# force version number in the soname
82
sed -i 's/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus-%{version}/' \
83
       source/CMakeLists.txt
84
85
%build
86
SOURCE_DIR="$PWD"/source
87
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON -Wno-dev"
88
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
89
90
%if 0%{?suse_version} >= 1500
91
%define __sourcedir ./source
92
93
# Build 10bit depth version of the library
94
%define __builddir ./source/build-10bit
95
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
96
%ifarch i586
97
      -DENABLE_ASSEMBLY=OFF
98
%endif
99
100
make %{?_smp_mflags}
101
cd ../..
102
103
# Build 12bit depth version of the library
104
%define __builddir ./source/build-12bit
105
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
106
%ifarch i586
107
      -DENABLE_ASSEMBLY=OFF
108
%endif
109
110
make %{?_smp_mflags}
111
cd ../..
112
113
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
114
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
115
116
# Build general version of the library linking in the 10/12bit depth versions
117
%define __builddir ./source/build
118
%cmake -DENABLE_TESTS=OFF \
119
       -DENABLE_SHARED=ON \
120
       -DX265_LATEST_TAG="%{sover}.0" \
121
       -DX265_VERSION="%{version}" \
122
       -DENABLE_HDR10_PLUS=ON \
123
       -DENABLE_PIC=ON \
124
       -DENABLE_CLI=ON \
125
       -DLINKED_10BIT=ON \
126
       -DLINKED_12BIT=ON \
127
       -DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
128
       -DEXTRA_LIB="x265_main10.a;x265_main12.a" \
129
       -Wno-dev
130
%else
131
cd source
132
%cmake $COMMON_FLAGS \
133
       -DENABLE_SHARED=ON \
134
       -DX265_LATEST_TAG="%{sover}.0" \
135
       -DX265_VERSION="%{version}" \
136
       -DENABLE_HDR10_PLUS=ON
137
%endif
138
make %{?_smp_mflags}
139
cd ../../
140
141
%install
142
%if 0%{?suse_version} < 1500
143
cd source
144
%endif
145
%cmake_install
146
find %{buildroot} -type f -name "*.a" -delete -print0
147
148
%post -n %{libsoname} -p /sbin/ldconfig
149
%postun -n %{libsoname} -p /sbin/ldconfig
150
151
%post -n libhdr10plus-%{uver} -p /sbin/ldconfig
152
%postun -n libhdr10plus-%{uver} -p /sbin/ldconfig
153
154
%files -n %{libsoname}
155
%{_libdir}/%{libname}.so.%{sover}*
156
157
%files -n libhdr10plus-%{uver}
158
%{_libdir}/libhdr10plus-%{version}.so
159
160
%files
161
%{_bindir}/%{name}
162
163
%files -n %{libname}-devel
164
%license COPYING
165
%doc readme.rst
166
%{_includedir}/%{name}.h
167
%{_includedir}/%{name}_config.h
168
%{_includedir}/hdr10plus.h
169
%{_libdir}/pkgconfig/%{name}.pc
170
%{_libdir}/%{libname}.so
171
172
%changelog
173