File x265.spec of Package x265 (Revision 41)
Currently displaying revision 41 , Show latest
158
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2021 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define sover 199
21
%define libname lib%{name}
22
%define libsoname %{libname}-%{sover}
23
%define uver 3_5
24
Name: x265
25
Version: 3.5
26
Release: 0
27
Summary: A free h265/HEVC encoder - encoder binary
28
License: GPL-2.0-or-later
29
Group: Productivity/Multimedia/Video/Editors and Convertors
30
URL: https://bitbucket.org/multicoreware/x265_git
31
Source0: https://bitbucket.org/multicoreware/x265_git/downloads/%{name}_%{version}.tar.gz
32
Patch0: arm.patch
33
Patch1: x265.pkgconfig.patch
34
Patch2: x265-fix_enable512.patch
35
BuildRequires: cmake >= 2.8.8
36
BuildRequires: gcc-c++
37
BuildRequires: nasm >= 2.13
38
BuildRequires: pkgconfig
39
%ifarch x86_64
40
BuildRequires: libnuma-devel >= 2.0.9
41
%endif
42
43
%description
44
x265 is a free library for encoding next-generation H265/HEVC video
45
streams.
46
47
%package -n %{libsoname}
48
Summary: A free H265/HEVC encoder - encoder binary
49
Group: Productivity/Multimedia/Video/Editors and Convertors
50
51
%description -n %{libsoname}
52
x265 is a free library for encoding next-generation H265/HEVC video
53
streams.
54
55
%package -n libhdr10plus-%{uver}
56
Summary: A free HDR10+ library
57
Group: Productivity/Multimedia/Video/Editors and Convertors
58
59
%description -n libhdr10plus-%{uver}
60
A free library supporting HDR10+.
61
62
%package -n %{libname}-devel
63
Summary: Libraries and include file for the %{libname} encoder
64
Group: Development/Libraries/C and C++
65
Requires: %{libsoname} = %{version}-%{release}
66
Requires: libhdr10plus-%{uver} = %{version}-%{release}
67
Provides: %{name}-devel = %{version}
68
Obsoletes: %{name}-devel < %{version}
69
70
%description -n %{libname}-devel
71
x265 is a free library for encoding next-generation H265/HEVC video
72
streams.
73
74
%prep
75
%setup -q -n %{name}_%{version}
76
%autopatch -p1
77
78
# set the version by hand
79
sed -i "/^include(Version)/d" source/CMakeLists.txt
80
# force version number in the soname
81
sed -i 's/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus-%{version}/' \
82
source/CMakeLists.txt
83
84
%build
85
SOURCE_DIR="$PWD"/source
86
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON -Wno-dev"
87
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
88
89
%define __sourcedir ./source
90
91
# Build 10bit depth version of the library
92
%define __builddir ./source/build-10bit
93
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
94
%ifarch i586
95
-DENABLE_ASSEMBLY=OFF
96
%endif
97
98
make %{?_smp_mflags}
99
cd ../..
100
101
# Build 12bit depth version of the library
102
%define __builddir ./source/build-12bit
103
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
104
%ifarch i586
105
-DENABLE_ASSEMBLY=OFF
106
%endif
107
108
make %{?_smp_mflags}
109
cd ../..
110
111
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
112
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
113
114
# Build general version of the library linking in the 10/12bit depth versions
115
%define __builddir ./source/build
116
%cmake $COMMON_FLAGS \
117
-DENABLE_SHARED=ON \
118
-DX265_LATEST_TAG="%{sover}.0" \
119
-DX265_VERSION="%{version}" \
120
-DENABLE_HDR10_PLUS=ON \
121
-DENABLE_CLI=ON \
122
-DLINKED_10BIT=ON \
123
-DLINKED_12BIT=ON \
124
-DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
125
-DEXTRA_LIB="x265_main10.a;x265_main12.a"
126
make %{?_smp_mflags}
127
cd ../../
128
129
%install
130
%cmake_install
131
find %{buildroot} -type f -name "*.a" -delete -print0
132
133
%post -n %{libsoname} -p /sbin/ldconfig
134
%postun -n %{libsoname} -p /sbin/ldconfig
135
136
%post -n libhdr10plus-%{uver} -p /sbin/ldconfig
137
%postun -n libhdr10plus-%{uver} -p /sbin/ldconfig
138
139
%files -n %{libsoname}
140
%{_libdir}/%{libname}.so.%{sover}*
141
142
%files -n libhdr10plus-%{uver}
143
%{_libdir}/libhdr10plus-%{version}.so
144
145
%files
146
%{_bindir}/%{name}
147
148
%files -n %{libname}-devel
149
%license COPYING
150
%doc readme.rst
151
%{_includedir}/%{name}.h
152
%{_includedir}/%{name}_config.h
153
%{_includedir}/hdr10plus.h
154
%{_libdir}/pkgconfig/%{name}.pc
155
%{_libdir}/%{libname}.so
156
157
%changelog
158