File x265.spec of Package x265 (Revision 42)

Currently displaying revision 42 , Show latest

161
 
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2024 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define sover   209
21
%define libname lib%{name}
22
%define libsoname %{libname}-%{sover}
23
%define uver    3_6
24
Name:           x265
25
Version:        3.6
26
Release:        0
27
Summary:        A free h265/HEVC encoder - encoder binary
28
License:        GPL-2.0-or-later
29
Group:          Productivity/Multimedia/Video/Editors and Convertors
30
URL:            https://bitbucket.org/multicoreware/x265_git
31
Source0:        https://bitbucket.org/multicoreware/x265_git/downloads/%{name}_%{version}.tar.gz
32
Patch1:         x265.pkgconfig.patch
33
Patch2:         x265-fix_enable512.patch
34
Patch3:         0001-Fix-arm-flags.patch
35
Patch4:         0004-Do-not-build-with-assembly-support-on-arm.patch
36
BuildRequires:  cmake >= 2.8.8
37
BuildRequires:  gcc-c++
38
BuildRequires:  nasm >= 2.13
39
BuildRequires:  pkgconfig
40
%ifarch x86_64
41
BuildRequires:  libnuma-devel >= 2.0.9
42
%endif
43
44
%description
45
x265 is a free library for encoding next-generation H265/HEVC video
46
streams.
47
48
%package -n %{libsoname}
49
Summary:        A free H265/HEVC encoder - encoder binary
50
Group:          Productivity/Multimedia/Video/Editors and Convertors
51
52
%description -n %{libsoname}
53
x265 is a free library for encoding next-generation H265/HEVC video
54
streams.
55
56
%package -n libhdr10plus-%{uver}
57
Summary:        A free HDR10+ library
58
Group:          Productivity/Multimedia/Video/Editors and Convertors
59
60
%description -n libhdr10plus-%{uver}
61
A free library supporting HDR10+.
62
63
%package -n %{libname}-devel
64
Summary:        Libraries and include file for the %{libname} encoder
65
Group:          Development/Libraries/C and C++
66
Requires:       %{libsoname} = %{version}-%{release}
67
Requires:       libhdr10plus-%{uver} = %{version}-%{release}
68
Provides:       %{name}-devel = %{version}
69
Obsoletes:      %{name}-devel < %{version}
70
71
%description -n %{libname}-devel
72
x265 is a free library for encoding next-generation H265/HEVC video
73
streams.
74
75
%prep
76
%setup -q -n %{name}_%{version}
77
%autopatch -p1
78
79
# set the version by hand
80
sed -i "/^include(Version)/d" source/CMakeLists.txt
81
# force version number in the soname
82
sed -i 's/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus-%{version}/' \
83
       source/CMakeLists.txt
84
85
%build
86
SOURCE_DIR="$PWD"/source
87
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON -Wno-dev"
88
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
89
90
%define __sourcedir ./source
91
92
# Build 10bit depth version of the library
93
%define __builddir ./source/build-10bit
94
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
95
%ifarch i586
96
      -DENABLE_ASSEMBLY=OFF
97
%endif
98
99
make %{?_smp_mflags}
100
cd ../..
101
102
# Build 12bit depth version of the library
103
%define __builddir ./source/build-12bit
104
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
105
%ifarch i586
106
      -DENABLE_ASSEMBLY=OFF
107
%endif
108
109
make %{?_smp_mflags}
110
cd ../..
111
112
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
113
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
114
115
# Build general version of the library linking in the 10/12bit depth versions
116
%define __builddir ./source/build
117
%cmake $COMMON_FLAGS \
118
       -DENABLE_SHARED=ON \
119
       -DX265_LATEST_TAG="%{sover}.0" \
120
       -DX265_VERSION="%{version}" \
121
       -DENABLE_HDR10_PLUS=ON \
122
       -DENABLE_CLI=ON \
123
       -DLINKED_10BIT=ON \
124
       -DLINKED_12BIT=ON \
125
       -DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
126
       -DEXTRA_LIB="x265_main10.a;x265_main12.a"
127
make %{?_smp_mflags}
128
cd ../../
129
130
%install
131
%cmake_install
132
find %{buildroot} -type f -name "*.a" -delete -print0
133
134
%check
135
136
%post -n %{libsoname} -p /sbin/ldconfig
137
%postun -n %{libsoname} -p /sbin/ldconfig
138
139
%post -n libhdr10plus-%{uver} -p /sbin/ldconfig
140
%postun -n libhdr10plus-%{uver} -p /sbin/ldconfig
141
142
%files -n %{libsoname}
143
%{_libdir}/%{libname}.so.%{sover}*
144
145
%files -n libhdr10plus-%{uver}
146
%{_libdir}/libhdr10plus-%{version}.so
147
148
%files
149
%{_bindir}/%{name}
150
151
%files -n %{libname}-devel
152
%license COPYING
153
%doc readme.rst
154
%{_includedir}/%{name}.h
155
%{_includedir}/%{name}_config.h
156
%{_includedir}/hdr10plus.h
157
%{_libdir}/pkgconfig/%{name}.pc
158
%{_libdir}/%{libname}.so
159
160
%changelog
161