File aMule.spec of Package aMule (Revision 63)
Currently displaying revision 63 , Show latest
148
1
#
2
# spec file for package aMule
3
#
4
# Copyright (c) 2021 Packman Team <packman@links2linux.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.links2linux.org/
16
#
17
18
19
Name: aMule
20
Version: 2.3.3.20250105.4a1b78a2a
21
Release: 0
22
Summary: Another eMule file-sharing program
23
License: GPL-2.0-or-later
24
Group: Productivity/Networking/Other
25
URL: https://www.amule.org
26
#https://github.com/amule-project/amule
27
Source: %name-%version.tar.xz
28
Patch: FTBFS-%name-leap-15.6.patch
29
BuildRequires: binutils-devel
30
BuildRequires: cmake
31
BuildRequires: fdupes
32
BuildRequires: gcc-c++
33
BuildRequires: man-pages-ro
34
BuildRequires: mozilla-nspr
35
BuildRequires: pkgconfig
36
BuildRequires: update-desktop-files
37
BuildRequires: wxWidgets-3_2-nostl-devel
38
%if 0%{?suse_version} == 1500
39
BuildRequires: libboost_headers1_75_0-devel
40
%else
41
BuildRequires: boost-devel
42
%endif
43
BuildRequires: readline-devel
44
BuildRequires: pkgconfig(cryptopp)
45
BuildRequires: pkgconfig(gdlib)
46
BuildRequires: pkgconfig(libpng)
47
BuildRequires: pkgconfig(libupnp)
48
Conflicts: aMule-kde4
49
50
%description
51
aMule stand for another eMule file-sharing program, it is also
52
another fork of the xMule (former lMule) project. It connects
53
to eDonkey2000 network, supports Linux, *BSD platforms, and has
54
a new vision of the GUI.
55
56
%lang_package
57
58
%prep
59
%autosetup -p1
60
61
%build
62
# remove shebang
63
sed -i '/^#!/d' src/utils/xas/xas.pl
64
#override version only for source 2.3.3.20250105.4a1b78a2a
65
if [[ %version == 2.3.3.20250105.4a1b78a2a ]]; then
66
sed -i '/VERSION "GIT"/s@.*@set (VERSION "2.3.3")\nset (SVNDATE "git 20250105")@' CMakeLists.txt
67
fi
68
69
%cmake \
70
-DBUILD_ALC=ON \
71
-DBUILD_ALCC=ON \
72
-DBUILD_AMULECMD=ON \
73
-DBUILD_CAS=ON \
74
-DBUILD_DAEMON=ON \
75
-DBUILD_ED2K=ON \
76
-DBUILD_FILEVIEW=ON \
77
-DBUILD_MONOLITHIC=ON \
78
-DBUILD_REMOTEGUI=ON \
79
-DBUILD_WEBSERVER=ON \
80
-DBUILD_WXCAS=ON \
81
-DBUILD_XAS=ON \
82
-DENABLE_UPNP=ON \
83
-DCMAKE_BUILD_TYPE=Release \
84
-DCMAKE_INSTALL_DOCDIR=%_defaultdocdir/%name
85
86
find /usr/include -type f -name "bmpbndl.h" -print
87
%cmake_build
88
89
%install
90
%cmake_install
91
92
%suse_update_desktop_file -G "P2P Client" -i amule Network P2P
93
%suse_update_desktop_file %buildroot%_datadir/applications/alc.desktop
94
%suse_update_desktop_file %buildroot%_datadir/applications/amulegui.desktop
95
%suse_update_desktop_file %buildroot%_datadir/applications/wxcas.desktop
96
97
rm %buildroot%_defaultdocdir/%name/{INSTALL,license.txt}
98
99
%find_lang %name --all-name --with-man
100
%if 0%{?suse_version} == 1500
101
echo '%dir %_mandir/tr' >>%name.lang
102
%endif
103
%fdupes %buildroot
104
105
%files
106
%license docs/license.txt
107
%doc docs/AUTHORS
108
%doc %_defaultdocdir/*
109
%_bindir/alc
110
%_bindir/alcc
111
%_bindir/amule
112
%_bindir/amulecmd
113
%_bindir/amuled
114
%_bindir/amulegui
115
%_bindir/amuleweb
116
%_bindir/autostart-xas
117
%_bindir/cas
118
%_bindir/ed2k
119
%_bindir/fileview
120
%_bindir/wxcas
121
%dir %_datadir/amule
122
%_datadir/amule/skins
123
%_datadir/amule/webserver
124
%_datadir/applications/alc.desktop
125
%_datadir/applications/amule.desktop
126
%_datadir/applications/amulegui.desktop
127
%_datadir/applications/wxcas.desktop
128
%_datadir/cas
129
%_datadir/pixmaps/*.xpm
130
%dir %_libdir/xchat
131
%dir %_libdir/xchat/plugins
132
%_libdir/xchat/plugins/xas.pl
133
%_mandir/man1/alc.1%{?ext_man}
134
%_mandir/man1/alcc.1%{?ext_man}
135
%_mandir/man1/amule.1%{?ext_man}
136
%_mandir/man1/amulecmd.1%{?ext_man}
137
%_mandir/man1/amuled.1%{?ext_man}
138
%_mandir/man1/amulegui.1%{?ext_man}
139
%_mandir/man1/amuleweb.1%{?ext_man}
140
%_mandir/man1/cas.1%{?ext_man}
141
%_mandir/man1/ed2k.1%{?ext_man}
142
%_mandir/man1/wxcas.1%{?ext_man}
143
%_mandir/man1/xas.1%{?ext_man}
144
145
%files lang -f %name.lang
146
147
%changelog
148