File python-scapy.spec of Package python-scapy (Revision 7a1e0ba36258322c033de2348867389d)
Currently displaying revision 7a1e0ba36258322c033de2348867389d , Show latest
68
1
#
2
# spec file for package python-scapy
3
#
4
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
Name: python-scapy
19
Version: 2.2.0
20
Release: 0
21
Summary: Interactive Packet Manipulation Tool
22
Source: http://www.secdev.org/projects/scapy/files/scapy-%{version}.tar.gz
23
Patch1: python-scapy-no-buildtime.patch
24
Url: http://www.secdev.org/projects/scapy/
25
Group: Productivity/Networking/Security
26
License: GPL-2.0
27
BuildRoot: %{_tmppath}/build-%{name}-%{version}
28
BuildRequires: python-devel
29
BuildRequires: python-sphinx
30
BuildArch: noarch
31
32
%description
33
Scapy is a powerful interactive packet manipulation tool, packet generator,
34
network scanner, network discovery tool, and packet sniffer. It provides
35
classes to interactively create packets or sets of packets, manipulate them,
36
send them over the wire, sniff other packets from the wire, match answers and
37
replies, and more. Interaction is provided by the Python interpreter, so Python
38
programming structures can be used (such as variables, loops, and functions).
39
Report modules are possible and easy to make. It is intended to do about the
40
same things as ttlscan, nmap, hping, queso, p0f, xprobe, arping, arp-sk,
41
arpspoof, firewalk, irpas, tethereal, tcpdump, etc.
42
43
%prep
44
%setup -q -n scapy-%{version}
45
%patch1 -p1
46
# For rpmlint warning: remove shebang from python library:
47
sed -i '/^#!/d' ./scapy/layers/inet6.py
48
sed -i '/^#!/d' ./scapy/tools/check_asdis.py
49
50
%build
51
python setup.py build
52
53
make -C doc/scapy html
54
rm doc/scapy/_build/html/.buildinfo doc/scapy/_build/html/_static/_dummy
55
56
%install
57
python setup.py install --prefix="%{_prefix}" --root="%{buildroot}"
58
59
%files
60
%defattr(-,root,root)
61
%doc doc/scapy/_build/html
62
%{_bindir}/UTscapy
63
%{_bindir}/scapy
64
%{python_sitelib}
65
%{_mandir}/man1/scapy.1%{ext_man}
66
67
%changelog
68