File vlc-beta.spec of Package vlc-beta (Revision 42198a9edce6a67117d283b3396dba0b)

Currently displaying revision 42198a9edce6a67117d283b3396dba0b , Show latest

561
 
1
#
2
# spec file for package vlc-beta
3
#
4
# Copyright (c) 2017 Packman team: http://packman.links2linux.org/
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.links2linux.org/
16
#
17
18
19
%global  _buildshell /bin/bash
20
%global __provides_exclude_from ^%_libdir/%name/[^/]+/.*\\.so(|\\.[0-9].*)$
21
%bcond_with    vlc_opencv
22
%bcond_with    fdk_aac
23
%ifarch %arm
24
%bcond_without opengles
25
%else
26
%bcond_with opengles
27
%endif
28
%bcond_with     vlc_medialibrary
29
Name:           vlc-beta
30
Version:        0
31
Release:        0
32
Summary:        Snapshot of vlc.git#master
33
License:        GPL-2.0+ and LGPL-2.1+
34
URL:            https://code.videolan.org/videolan/vlc
35
Source0:        %name-%version.tar
36
Source1:        %name.changes
37
Source3:        %name-rpmlintrc
38
Patch0:         vlc-beta.patch
39
40
# avoid stale debug.rpm
41
Conflicts:      %name-debuginfo < %version-%release 
42
Conflicts:      %name-debugsource < %version-%release 
43
#
44
Conflicts:      vlc
45
Conflicts:      vlc-codec-fluidsynth
46
Conflicts:      vlc-codec-fluidsynth-debuginfo
47
Conflicts:      vlc-codec-gstreamer
48
Conflicts:      vlc-codec-gstreamer-debuginfo
49
Conflicts:      vlc-codecs
50
Conflicts:      vlc-codecs-debuginfo
51
Conflicts:      vlc-debuginfo
52
Conflicts:      vlc-debugsource
53
Conflicts:      vlc-devel
54
Conflicts:      vlc-jack
55
Conflicts:      vlc-jack-debuginfo
56
Conflicts:      vlc-lang
57
Conflicts:      vlc-noX
58
Conflicts:      vlc-noX-debuginfo
59
Conflicts:      vlc-opencv
60
Conflicts:      vlc-opencv-debuginfo
61
Conflicts:      vlc-qt
62
Conflicts:      vlc-qt-debuginfo
63
Conflicts:      vlc-vdpau
64
Conflicts:      vlc-vdpau-debuginfo
65
#
66
Obsoletes:      libvlc123 < %version-%release
67
Obsoletes:      libvlc123-debuginfo < %version-%release
68
Obsoletes:      libvlccore123 < %version-%release
69
Obsoletes:      libvlccore123-debuginfo < %version-%release
70
Obsoletes:      vlc-beta-devel < %version-%release
71
Obsoletes:      vlc-beta-noX < %version-%release
72
Obsoletes:      vlc-beta-noX-debuginfo < %version-%release
73
Obsoletes:      vlc-beta-noX-lang < %version-%release
74
Obsoletes:      vlc-beta-qt < %version-%release
75
Obsoletes:      vlc-beta-qt-debuginfo < %version-%release
76
Provides:       libvlc123 = %version-%release
77
Provides:       libvlc123-debuginfo = %version-%release
78
Provides:       libvlccore123 = %version-%release
79
Provides:       libvlccore123-debuginfo = %version-%release
80
Provides:       vlc-beta-devel = %version-%release
81
Provides:       vlc-beta-noX = %version-%release
82
Provides:       vlc-beta-noX-debuginfo = %version-%release
83
Provides:       vlc-beta-noX-lang = %version-%release
84
Provides:       vlc-beta-qt = %version-%release
85
Provides:       vlc-beta-qt-debuginfo = %version-%release
86
87
BuildRequires:  bash
88
BuildRequires:  bison
89
BuildRequires:  ffmpeg-7-libavcodec-devel
90
BuildRequires:  ffmpeg-7-libavformat-devel
91
BuildRequires:  ffmpeg-7-libavutil-devel
92
BuildRequires:  ffmpeg-7-libpostproc-devel
93
BuildRequires:  ffmpeg-7-libswscale-devel
94
BuildRequires:  flex
95
BuildRequires:  gettext-devel >= 0.21
96
BuildRequires:  gettext-tools
97
BuildRequires:  libgcrypt-devel >= 1.6.0
98
BuildRequires:  libtool
99
BuildRequires:  pkg-config
100
%if 0%{?suse_version} > 1500
101
BuildRequires:  pkgconfig(KF6WindowSystem)
102
%endif
103
BuildRequires:  pkgconfig(Qt6Core)
104
BuildRequires:  pkgconfig(Qt6Gui)
105
BuildRequires:  pkgconfig(Qt6Qml)
106
BuildRequires:  pkgconfig(Qt6QmlModels)
107
BuildRequires:  pkgconfig(Qt6QmlWorkerScript)
108
BuildRequires:  pkgconfig(Qt6Quick)
109
BuildRequires:  pkgconfig(Qt6QuickControls2)
110
BuildRequires:  pkgconfig(Qt6QuickLayouts)
111
BuildRequires:  pkgconfig(Qt6QuickTemplates2)
112
BuildRequires:  pkgconfig(Qt6ShaderTools)
113
BuildRequires:  pkgconfig(Qt6Svg)
114
BuildRequires:  pkgconfig(Qt6WaylandClient)
115
BuildRequires:  pkgconfig(Qt6Widgets)
116
BuildRequires:  pkgconfig(alsa) >= 1.0.24
117
BuildRequires:  pkgconfig(avahi-client) >= 0.6
118
BuildRequires:  pkgconfig(caca) >= 0.99.beta14
119
BuildRequires:  pkgconfig(cairo) >= 1.13.1
120
BuildRequires:  pkgconfig(dav1d)
121
BuildRequires:  pkgconfig(dbus-1) >= 1.6.0
122
BuildRequires:  pkgconfig(dvdnav) >= 6.0.0
123
BuildRequires:  pkgconfig(dvdread) >= 6.0.0
124
BuildRequires:  pkgconfig(egl)
125
BuildRequires:  pkgconfig(faad2)
126
%if %{with fdk_aac}
127
BuildRequires:  pkgconfig(fdk-aac)
128
%endif
129
BuildRequires:  pkgconfig(ffnvcodec)
130
BuildRequires:  pkgconfig(flac)
131
BuildRequires:  pkgconfig(fluidsynth) >= 1.1.2
132
BuildRequires:  pkgconfig(fontconfig) >= 2.11
133
BuildRequires:  pkgconfig(freerdp2)
134
BuildRequires:  pkgconfig(freetype2)
135
BuildRequires:  pkgconfig(fribidi)
136
BuildRequires:  pkgconfig(gbm)
137
BuildRequires:  pkgconfig(gl)
138
BuildRequires:  pkgconfig(gnutls) >= 3.5.0
139
BuildRequires:  pkgconfig(gtk+-3.0)
140
BuildRequires:  pkgconfig(harfbuzz)
141
BuildRequires:  pkgconfig(jack) >= 1.9.7
142
BuildRequires:  pkgconfig(kate) >= 0.3.0
143
BuildRequires:  pkgconfig(libarchive) >= 3.1.0
144
BuildRequires:  pkgconfig(libass) >= 0.9.8
145
BuildRequires:  pkgconfig(libavc1394) >= 0.5.3
146
BuildRequires:  pkgconfig(libbluray)
147
BuildRequires:  pkgconfig(libcddb) >= 0.9.5
148
%if 0%{?suse_version} > 1500
149
BuildRequires:  pkgconfig(libchromaprint) >= 0.6.0
150
%endif
151
BuildRequires:  pkgconfig(libdc1394-2) >= 2.1.0
152
BuildRequires:  pkgconfig(libdrm) >= 2.4.83
153
BuildRequires:  pkgconfig(libdvbpsi) >= 1.2.0
154
BuildRequires:  pkgconfig(libebml) >= 1.3.6
155
BuildRequires:  pkgconfig(libebur128) >= 1.2.4
156
BuildRequires:  pkgconfig(libgme)
157
BuildRequires:  pkgconfig(libidn)
158
BuildRequires:  pkgconfig(libjpeg)
159
BuildRequires:  pkgconfig(libmatroska)
160
BuildRequires:  pkgconfig(libmodplug)
161
BuildRequires:  pkgconfig(libmpg123)
162
BuildRequires:  pkgconfig(libmtp) >= 1.0.0
163
BuildRequires:  pkgconfig(libnfs) >= 1.10.0
164
BuildRequires:  pkgconfig(libnotify)
165
BuildRequires:  pkgconfig(libpipewire-0.3)
166
BuildRequires:  pkgconfig(libplacebo)
167
BuildRequires:  pkgconfig(libpng)
168
BuildRequires:  pkgconfig(libpulse) >= 6.0
169
BuildRequires:  pkgconfig(libraw1394) >= 2.0.1
170
BuildRequires:  pkgconfig(librsvg-2.0) >= 2.9.0
171
BuildRequires:  pkgconfig(libsecret-1) >= 0.18
172
BuildRequires:  pkgconfig(libssh2)
173
BuildRequires:  pkgconfig(libsystemd)
174
BuildRequires:  pkgconfig(libudev) >= 142
175
BuildRequires:  pkgconfig(libupnp)
176
BuildRequires:  pkgconfig(libv4l2)
177
BuildRequires:  pkgconfig(libva) >= 0.38
178
BuildRequires:  pkgconfig(libva-drm)
179
BuildRequires:  pkgconfig(libva-wayland)
180
BuildRequires:  pkgconfig(libva-x11)
181
BuildRequires:  pkgconfig(libvncclient) >= 0.9.9
182
BuildRequires:  pkgconfig(libxml-2.0) >= 2.5
183
BuildRequires:  pkgconfig(lirc)
184
BuildRequires:  pkgconfig(live555) >= 2015.01.27
185
BuildRequires:  pkgconfig(lua) >= 5.1
186
BuildRequires:  pkgconfig(mad)
187
%if %{with vlc_medialibrary}
188
BuildRequires:  pkgconfig(medialibrary)
189
%endif
190
BuildRequires:  pkgconfig(ncursesw)
191
BuildRequires:  pkgconfig(ogg) >= 1.0
192
%if %{with vlc_opencv}
193
BuildRequires:  pkgconfig(opencv) > 2.0
194
%endif
195
BuildRequires:  pkgconfig(opus) >= 1.0.3
196
BuildRequires:  pkgconfig(protobuf-lite)
197
BuildRequires:  pkgconfig(python3)
198
BuildRequires:  pkgconfig(rav1e)
199
BuildRequires:  pkgconfig(samplerate)
200
BuildRequires:  pkgconfig(schroedinger-1.0) >= 1.0.10
201
BuildRequires:  pkgconfig(shine) >= 3.0.0
202
BuildRequires:  pkgconfig(shout) >= 2.1
203
BuildRequires:  pkgconfig(smbclient)
204
BuildRequires:  pkgconfig(soxr) >= 0.1.2
205
BuildRequires:  pkgconfig(speex) >= 1.0.5
206
BuildRequires:  pkgconfig(taglib) >= 1.11
207
BuildRequires:  pkgconfig(theoradec) >= 1.0
208
BuildRequires:  pkgconfig(theoraenc)
209
BuildRequires:  pkgconfig(twolame)
210
BuildRequires:  pkgconfig(vdpau) >= 0.6
211
BuildRequires:  pkgconfig(vorbis) >= 1.1
212
BuildRequires:  pkgconfig(vorbisenc) >= 1.1
213
BuildRequires:  pkgconfig(vpx) >= 1.5.0
214
BuildRequires:  pkgconfig(vulkan) >= 1.0.26
215
BuildRequires:  pkgconfig(wayland-client)
216
BuildRequires:  pkgconfig(wayland-cursor)
217
BuildRequires:  pkgconfig(wayland-egl)
218
BuildRequires:  pkgconfig(wayland-protocols) >= 1.15
219
BuildRequires:  pkgconfig(wayland-scanner) >= 1.15
220
BuildRequires:  pkgconfig(x264) >= 0.86
221
BuildRequires:  pkgconfig(x265)
222
BuildRequires:  pkgconfig(xcb) >= 1.6
223
BuildRequires:  pkgconfig(xcb-composite)
224
BuildRequires:  pkgconfig(xcb-damage)
225
BuildRequires:  pkgconfig(xcb-keysyms) >= 0.3.4
226
BuildRequires:  pkgconfig(xcb-randr) >= 1.3
227
BuildRequires:  pkgconfig(xcb-render)
228
BuildRequires:  pkgconfig(xcb-shm) >= 1.9.2
229
BuildRequires:  pkgconfig(xcb-xfixes)
230
BuildRequires:  pkgconfig(xcb-xkb)
231
BuildRequires:  pkgconfig(xcursor)
232
BuildRequires:  pkgconfig(xext)
233
BuildRequires:  pkgconfig(xinerama)
234
BuildRequires:  pkgconfig(xkbcommon)
235
BuildRequires:  pkgconfig(xkbcommon-x11)
236
BuildRequires:  pkgconfig(xpm)
237
BuildRequires:  pkgconfig(xproto)
238
BuildRequires:  pkgconfig(zlib)
239
BuildRequires:  pkgconfig(zvbi-0.2) >= 0.2.28
240
BuildRequires:  qt6qmlimport(Qt5Compat.GraphicalEffects.1)
241
BuildRequires:  qt6qmlimport(QtQuick.Controls.6)
242
BuildRequires:  qt6qmlimport(QtQuick.Window.2)
243
244
BuildRequires:  fdupes
245
BuildRequires:  update-desktop-files
246
247
Requires:       qt6qmlimport(Qt5Compat.GraphicalEffects.1)
248
Requires:       qt6qmlimport(QtQuick.Controls.6)
249
Requires:       qt6qmlimport(QtQuick.Window.2)
250
251
%description
252
VLC media player is a multimedia player.
253
It can also be used as a server to stream in unicast or multicast.
254
255
%prep
256
%autosetup -p1
257
258
%build
259
head -n 123 /proc/cpuinfo /proc/cmdline || :
260
uname -a
261
VERSION=%version
262
echo "${VERSION##*.}" > ./src/revision.txt
263
VERSION_MAJOR=${VERSION:0:2}
264
VERSION_MINOR=${VERSION:2:2}
265
VERSION_REVISION=${VERSION:4:2}
266
VERSION_REVISION=${VERSION_REVISION#0*}
267
VERSION_EXTRA=${VERSION:6:2}
268
VERSION_EXTRA=${VERSION_EXTRA#0*}
269
VERSION_DEV=${VERSION#*.}
270
sed -i~ "
271
s@^AC_INIT.*@AC_INIT([%name], [${VERSION%%.*}])@
272
s@^VERSION_MAJOR=.@VERSION_MAJOR=${VERSION_MAJOR}@
273
s@^VERSION_MINOR=.@VERSION_MINOR=${VERSION_MINOR}@
274
s@^VERSION_REVISION=.@VERSION_REVISION=${VERSION_REVISION}@
275
s@^VERSION_EXTRA=.@VERSION_EXTRA=${VERSION_EXTRA}@
276
s@^VERSION_DEV=.@VERSION_DEV=${VERSION_DEV}@
277
" configure.ac
278
diff -u "$_"~ "$_" && exit 1
279
sed -i~ "
280
/define[[:blank:]]\\+LIBVLC_VERSION_MAJOR/s@^.*@#define LIBVLC_VERSION_MAJOR ${VERSION_MAJOR}@
281
/define[[:blank:]]\\+LIBVLC_VERSION_MINOR/s@^.*@#define LIBVLC_VERSION_MINOR ${VERSION_MINOR}@
282
/define[[:blank:]]\\+LIBVLC_VERSION_REVISION/s@^.*@#define LIBVLC_VERSION_REVISION ${VERSION_REVISION}@
283
/define[[:blank:]]\\+LIBVLC_VERSION_EXTRA/s@^.*@#define LIBVLC_VERSION_EXTRA ${VERSION_EXTRA}@
284
" include/vlc/libvlc_version.h
285
diff -u "$_"~ "$_" && exit 1
286
# fix builddate info
287
# Remove build time references so build-compare can do its work
288
FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{SOURCE1} '+%%H:%%M')
289
FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{SOURCE1} '+%%b %%e %%Y')
290
sed -i~ "
291
s/__TIME__/\"$FAKE_BUILDTIME\"/
292
s/__DATE__/\"$FAKE_BUILDDATE\"/
293
" src/config/help.c modules/gui/qt/dialogs/help/help.cpp
294
#
295
#
296
export VLC_COMPILE_BY='X'
297
export VLC_COMPILE_HOST='X'
298
test -x "$(type -p gcc)"    && BUILDCC="$_"
299
test -x "$(type -p gcc)"    && CC="$_"
300
test -x "$(type -p g++)"    && CXX="$_"
301
test -x "$(type -p gcc-10)" && BUILDCC="$_"
302
test -x "$(type -p gcc-10)" && CC="$_"
303
test -x "$(type -p g++-10)" && CXX="$_"
304
test -x "$(type -p gcc-13)" && BUILDCC="$_"
305
test -x "$(type -p gcc-13)" && CC="$_"
306
test -x "$(type -p g++-13)" && CXX="$_"
307
export BUILDCC="$(readlink -f ${BUILDCC})"
308
export CC="$(readlink -f ${CC})"
309
export CXX="$(readlink -f ${CXX})"
310
CFLAGS='%optflags -Wno-unused-variable -Wno-unused-parameter -Wno-deprecated-declarations -Wno-unused-but-set-variable'
311
CXXFLAGS='%optflags -Wno-unused-variable -Wno-unused-parameter -Wno-deprecated-declarations -Wno-unused-but-set-variable'
312
./bootstrap
313
%configure --help
314
%configure \
315
    --without-contrib \
316
    --without-libfuzzer \
317
    --enable-shared \
318
    --enable-dbus \
319
    --disable-avx \
320
    --disable-chromecast \
321
    --disable-debug \
322
    --disable-gprof \
323
    --disable-cprof \
324
    --disable-coverage \
325
    --disable-mod \
326
    --disable-nls \
327
    --disable-opencv \
328
    --without-sanitizer \
329
    --enable-optimizations \
330
    --disable-fdkaac \
331
    --disable-sse \
332
    --disable-neon \
333
    --disable-altivec \
334
%ifarch %ix86 x86_64
335
    --enable-sse \
336
%endif
337
%ifarch aarch64
338
    --enable-arm64 \
339
%endif
340
    --disable-optimize-memory \
341
    --disable-run-as-root \
342
    --enable-sout \
343
    --enable-lua \
344
    --enable-vlm \
345
    --enable-addonmanagermodules \
346
    --enable-archive \
347
    --enable-live555 \
348
    --enable-dc1394 \
349
    --enable-dv1394 \
350
    --enable-linsys \
351
    --enable-dvdread \
352
    --enable-dvdnav \
353
    --enable-bluray \
354
%if %{with vlc_opencv}
355
    --enable-opencv \
356
%endif
357
    --enable-smbclient \
358
    --disable-dsm \
359
    --enable-sftp \
360
    --enable-nfs \
361
    --enable-v4l2 \
362
    --disable-decklink \
363
    --enable-vcd \
364
    --enable-libcddb \
365
    --disable-screen \
366
    --enable-vnc \
367
    --enable-freerdp \
368
    --disable-macosx-avfoundation \
369
    --disable-asdcp \
370
    --enable-dvbpsi \
371
    --enable-gme \
372
    --disable-sid \
373
    --enable-ogg \
374
%if 0
375
    --enable-shout \
376
%endif
377
    --enable-matroska \
378
    --enable-mod \
379
    --disable-mpc \
380
    --disable-omxil \
381
    --disable-rpi-omxil \
382
    --enable-mad \
383
    --enable-mpg123 \
384
    --disable-gst-decode \
385
    --enable-merge-ffmpeg \
386
    --enable-avcodec \
387
    --enable-libva \
388
    --disable-dxva2 \
389
    --disable-d3d11va \
390
    --enable-avformat \
391
    --enable-swscale \
392
    --enable-postproc \
393
    --enable-faad \
394
    --disable-aom \
395
    --enable-rav1e \
396
    --enable-dav1d \
397
    --enable-vpx \
398
    --enable-twolame \
399
%if %{with fdk_aac}
400
    --enable-fdkaac \
401
%endif
402
    --enable-flac \
403
    --enable-vorbis \
404
    --disable-tremor \
405
    --enable-speex \
406
    --enable-opus \
407
    --disable-spatialaudio \
408
    --enable-theora \
409
    --enable-oggspots \
410
    --disable-daala \
411
    --enable-schroedinger \
412
    --enable-png \
413
    --enable-jpeg \
414
    --disable-x262 \
415
    --enable-x265 \
416
    --disable-x26410b \
417
    --enable-x264 \
418
    --enable-fluidsynth \
419
    --disable-fluidlite \
420
    --enable-zvbi \
421
    --disable-telx \
422
    --enable-libass \
423
    --disable-aribsub \
424
    --disable-aribb25 \
425
    --enable-kate \
426
    --disable-tiger \
427
    --enable-css \
428
    --disable-gles2 \
429
%if %{with opengles}
430
    --enable-gles2 \
431
%endif
432
    --enable-xcb \
433
    --enable-vdpau \
434
%if 0
435
    --enable-wayland \
436
%endif
437
    --enable-freetype \
438
    --enable-fribidi \
439
    --enable-harfbuzz \
440
    --enable-fontconfig \
441
    --with-default-font=%_datadir/fonts/truetype/FreeSerifBold.ttf \
442
    --with-default-monospace-font=%_datadir/fonts/truetype/FreeMono.ttf \
443
    --enable-svg \
444
    --enable-svgdec \
445
    --disable-directx \
446
    --enable-caca \
447
    --disable-kva \
448
    --disable-mmal \
449
    --enable-pipewire \
450
    --enable-pulse \
451
    --enable-alsa \
452
    --disable-oss \
453
    --disable-sndio \
454
    --disable-wasapi \
455
    --enable-jack \
456
    --disable-opensles \
457
    --enable-samplerate \
458
    --enable-soxr \
459
    --disable-kai \
460
%if 0%{?suse_version} > 1500
461
    --enable-chromaprint \
462
%endif
463
    --enable-chromecast \
464
    --enable-qt \
465
    --enable-qt \
466
    --enable-skins2 \
467
    --disable-macosx \
468
    --disable-sparkle \
469
    --without-breakpad \
470
    --disable-minimal-macosx \
471
    --disable-ncurses \
472
    --enable-ncurses \
473
    --enable-lirc \
474
    --disable-srt \
475
    --disable-goom \
476
    --disable-projectm \
477
    --disable-vsxu \
478
    --enable-avahi \
479
    --enable-udev \
480
    --enable-mtp \
481
    --enable-upnp \
482
    --disable-microdns \
483
    --enable-libxml2 \
484
    --enable-libgcrypt \
485
    --enable-gnutls \
486
    --enable-taglib \
487
    --enable-secret \
488
    --enable-kwallet \
489
    --disable-update-check \
490
    --disable-osx-notifications \
491
    --enable-gbm \
492
    --enable-notify \
493
    --disable-vulkan \
494
%if 0
495
    --enable-libplacebo \
496
%endif
497
    --enable-vulkan \
498
%if %{with vlc_medialibrary}
499
    --enable-medialibrary \
500
%else
501
    --disable-medialibrary \
502
%endif
503
    --with-kde-solid=%_datadir/kde4/apps/solid \
504
    --enable-vlc \
505
    --enable-nls \
506
    %nil
507
508
%make_build --no-print-directory
509
510
%install
511
%make_install
512
mkdir -p %buildroot/%_datadir/pixmaps
513
ln -s %_datadir/icons/hicolor/48x48/apps/vlc.png %buildroot/%_datadir/pixmaps/vlc.png
514
find %buildroot -type f -name "*.la" -delete -print
515
find %buildroot -type f -name "*.a" -delete -print
516
rm -rfv %buildroot%_datadir/macosx
517
rm -rfv %buildroot%_datadir/doc
518
%suse_update_desktop_file vlc AudioVideo Audio Video Player
519
%fdupes %buildroot
520
# add missing manfiles
521
for i in ?vlc; do
522
    pushd %buildroot/%_mandir/man1
523
    ln -s vlc.1 $i.1
524
    popd
525
done
526
> %name.lang
527
%find_lang %name
528
read s < <(stat -c %%s %buildroot%_libdir/%name/plugins/plugins.dat)
529
fallocate --punch-hole --offset 0 --length "${s}" %buildroot%_libdir/%name/plugins/plugins.dat
530
(
531
echo '%%ghost %buildroot%_libdir/%name/plugins/plugins.dat'
532
find %buildroot%_libdir/%name -type d -printf '%%%%dir %p\n'
533
find %buildroot%_libdir/%name -type f -name "*.so" -printf '%p\n'
534
)|sed 's|%buildroot||'|sort -u|tee -a %name.lang
535
536
%post -p /sbin/ldconfig
537
538
%postun -p /sbin/ldconfig
539
540
%posttrans
541
exec %_libexecdir/%name/vlc-cache-gen %_libdir/%name/plugins
542
543
%files -f %name.lang
544
%_bindir/*
545
%_datadir/%name
546
%_datadir/applications/*
547
%_datadir/icons/*
548
%_datadir/kde4
549
%_datadir/metainfo/*
550
%_datadir/pixmaps/*
551
%_includedir/*
552
%_libdir/%name/*.so
553
%_libdir/%name/*.so.*
554
%_libdir/*.so
555
%_libdir/*.so.*
556
%_libdir/pkgconfig/*.pc
557
%_libexecdir/%name
558
%_mandir/*/*
559
560
%changelog
561