File djv.spec of Package djv (Revision e8b07c64b4977948adadebacab610ce7)
Currently displaying revision e8b07c64b4977948adadebacab610ce7 , Show latest
217
1
#
2
# spec file for package djv
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.links2linux.org/
16
#
17
18
%define soname 0
19
Name: djv
20
Version: 1.0.5.20150809.a7104da
21
Release: 0
22
Summary: DJV Imaging
23
License: GPL-2.0
24
Group: Productivity/Graphics/Viewers
25
Url: http://djv.sourceforge.net/
26
Source0: http://git.code.sf.net/p/djv/git#/%{name}-%{version}.tar.xz
27
# PATCH-FIX-OPENSUSE include.patch avvissu@yandex.ru -- Don't include depending when packaging
28
Patch1: djv-1.0.5_include.patch
29
# PATCH-FIX-OPENSUSE path.patch avvissu@yandex.ru -- Change the default installation path
30
Patch2: djv-1.0.5_path.patch
31
# PATCH-FIX-UPSTREAM link_library.patch avvissu@yandex.ru -- Build with --no-undefined
32
Patch4: djv-1.0.5_link_library.patch
33
# PATCH-FIX-UPSTREAM qt5-5.5.patch avvissu@yandex.ru -- Fix build with Qt5 >= 5.5
34
Patch5: djv-1.0.5_qt5-5.5.patch
35
Patch6: djv-ffmpeg.patch
36
Patch7: djv-runtime_paths.patch
37
BuildRequires: cmake >= 3.0
38
BuildRequires: doxygen
39
BuildRequires: fdupes
40
BuildRequires: gcc-c++
41
BuildRequires: shared-mime-info
42
BuildRequires: hicolor-icon-theme
43
# Recommended jpegsrc.v9 instead of libjpeg-turbo
44
BuildRequires: libjpeg-devel
45
BuildRequires: pkg-config
46
BuildRequires: update-desktop-files
47
BuildRequires: pkgconfig(IlmBase) >= 2.2.0
48
BuildRequires: pkgconfig(OpenEXR) >= 2.2.0
49
BuildRequires: cmake(Qt5Concurrent)
50
BuildRequires: cmake(Qt5Core) >= 5.3.0
51
BuildRequires: cmake(Qt5LinguistTools)
52
BuildRequires: cmake(Qt5OpenGL)
53
BuildRequires: cmake(Qt5Svg)
54
BuildRequires: cmake(Qt5Widgets)
55
BuildRequires: pkgconfig(glew) >= 1.10.0
56
BuildRequires: pkgconfig(glu)
57
BuildRequires: pkgconfig(libavcodec)
58
BuildRequires: pkgconfig(libavformat)
59
BuildRequires: pkgconfig(libavutil)
60
BuildRequires: pkgconfig(libpng) >= 1.6.8
61
BuildRequires: pkgconfig(libswscale)
62
BuildRequires: pkgconfig(libtiff-4) >= 4.0.3
63
BuildRequires: pkgconfig(zlib) >= 1.2.8
64
Recommends: %{name}-doc
65
Requires: lib%{name}Core%{soname} = %{version}-%{release}
66
ExcludeArch: %{arm}
67
68
%description
69
Professional movie playback software for film production, VFX, and
70
computer animation. Key features include:
71
* real-time playback of image sequences and movies
72
* support for industry standard file formats including Cineon, DPX,
73
OpenEXR, and QuickTime
74
* command line utilities for batch processing
75
76
%package -n lib%{name}Core%{soname}
77
Summary: C++ library for realtime MIDI input/ouput
78
Group: System/Libraries
79
Provides: lib%{name}%{soname} = %{version}-%{release}
80
Provides: lib%{name}Gui%{soname} = %{version}-%{release}
81
Provides: lib%{name}ViewLib%{soname} = %{version}-%{release}
82
83
%description -n lib%{name}Core%{soname}
84
Professional movie playback software for film production, VFX, and
85
computer animation.
86
87
This package provides the shared libraries.
88
89
%package plugins
90
Summary: DJV plugins
91
Group: Productivity/Graphics/Viewers
92
Requires: %{name} = %{version}-%{release}
93
94
%description plugins
95
Professional movie playback software for film production, VFX, and
96
computer animation.
97
98
This package contains plugins for %{name} apps:
99
* Cineon, DPX, IFF, IFL, JPEG, LUT, OpenEXR, PIC, PNG, PPM, RLA, SGI,
100
TIFF, Targa
101
102
%package devel
103
Summary: Development files for %{name}
104
Group: Development/Libraries/C and C++
105
Requires: lib%{name}%{soname} = %{version}-%{release}
106
Provides: %{name}Core = %{version}-%{release}
107
Provides: %{name}Gui = %{version}-%{release}
108
Provides: %{name}ViewLib = %{version}-%{release}
109
110
%description devel
111
Professional movie playback software for film production, VFX, and
112
computer animation.
113
114
This package contains header files and libraries needed to develop
115
application that use %{name}.
116
117
%package doc
118
Summary: Documentation for %{name}
119
Group: Documentation/HTML
120
BuildArch: noarch
121
122
%description doc
123
Professional movie playback software for film production, VFX, and
124
computer animation.
125
126
Help documentation for %{name}.
127
128
%prep
129
%setup -q -n %{name}-%{version}
130
131
%patch1 -p1
132
%patch2 -p1
133
%patch4 -p1
134
%patch5 -p1
135
%patch6 -p1
136
%patch7 -p1
137
138
# Change exec-path
139
sed -i '/Exec/s|[/].*|%{name}_view|' $(grep -rl 'djv_view.sh')
140
sed -i~ /tests/d CMakeLists.txt
141
142
%build
143
%cmake \
144
-DCMAKE_SKIP_RPATH=OFF
145
146
make %{?_smp_mflags}
147
148
%install
149
%cmake_install
150
find %{buildroot} -ls
151
152
mv -v %{buildroot}%{_prefix}/translations %{buildroot}%{_libdir}/%{name}
153
154
# Search and load all plugins
155
d="%{buildroot}"
156
for f in `ls $d%{_bindir}/%{name}*`; do
157
b=$(basename $f)
158
mv $f $d%{_libdir}/%{name}/
159
ln -s %{_libdir}/%{name}/$b $d%{_bindir}/$b; done
160
161
%suse_update_desktop_file -r %{name}_view Qt Graphics Viewer
162
163
%fdupes -s %{buildroot}/%{_datadir}
164
165
%check
166
# Only local test
167
#sed -i '/ctest/s|\(bin/ctest\)|\1 -V|' build/Makefile
168
#make test -C build
169
170
%post -n lib%{name}Core%{soname} -p /sbin/ldconfig
171
172
%postun -n lib%{name}Core%{soname} -p /sbin/ldconfig
173
174
%post
175
%mime_database_post
176
%desktop_database_post
177
%icon_theme_cache_post
178
179
%postun
180
%mime_database_postun
181
%desktop_database_postun
182
%icon_theme_cache_postun
183
184
%files
185
%defattr(-,root,root)
186
%doc LICENSE README
187
%{_bindir}/%{name}_convert
188
%{_bindir}/%{name}_info
189
%{_bindir}/%{name}_ls
190
%{_bindir}/%{name}_view
191
%{_libdir}/%{name}
192
%{_datadir}/applications/%{name}_view.desktop
193
%{_datadir}/mime/packages/%{name}_view*.xml
194
%{_datadir}/icons/hicolor/*/apps/%{name}_view.png
195
%exclude %{_libdir}/%{name}/lib%{name}*Plugin.so
196
197
%files -n lib%{name}Core%{soname}
198
%defattr(-,root,root)
199
%{_libdir}/lib%{name}*.so.*
200
201
%files plugins
202
%defattr(-,root,root)
203
%{_libdir}/%{name}/lib%{name}*Plugin.so
204
205
%files devel
206
%defattr(-,root,root)
207
%{_includedir}/%{name}*.h
208
%{_libdir}/lib%{name}*.so
209
210
%files doc
211
%defattr(-,root,root)
212
%dir %{_datadir}/%{name}
213
%dir %{_datadir}/%{name}/doc
214
%{_datadir}/%{name}/doc
215
216
%changelog
217