File flacon.spec of Package flacon (Revision f55acfd9ef52253b0a8a8fdf8c275c3f)

Currently displaying revision f55acfd9ef52253b0a8a8fdf8c275c3f , Show latest

111
 
1
#
2
# spec file for package flacon
3
#
4
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.links2linux.org/
16
#
17
18
19
Name:           flacon
20
Version:        0.9.1
21
Release:        0
22
License:        LGPL-2.1+
23
Summary:        Split Compressed Audio CD Image to Tracks
24
Url:            https://github.com/SokoloffA/flacon
25
Group:          Productivity/Multimedia/Sound/Editors and Convertors
26
Source0:        https://github.com/SokoloffA/flacon/archive/v%{version}.tar.gz
27
# PATCH-FIX-UPSTREAM flacon-0.9.1-qt_version_check.patch <sokoloff.a@gmail.com> -- fix compile with Qt < 4.8.0
28
Patch0:         flacon-0.9.1-qt_version_check.patch
29
BuildRequires:  cmake
30
BuildRequires:  hicolor-icon-theme
31
BuildRequires:  update-desktop-files
32
BuildRequires:  pkgconfig(QtCore)
33
BuildRequires:  pkgconfig(QtGui)
34
BuildRequires:  pkgconfig(QtNetwork)
35
BuildRequires:  pkgconfig(uchardet)
36
# not actually needed for build, but in order to make the build fail
37
# if the runtime dependencies are not available in the repository:
38
BuildRequires:  faac
39
BuildRequires:  flac
40
BuildRequires:  lame
41
BuildRequires:  mac
42
BuildRequires:  shntool
43
BuildRequires:  ttaenc
44
BuildRequires:  vorbis-tools
45
BuildRequires:  wavpack
46
Requires:       faac
47
Requires:       flac
48
Requires:       lame
49
Requires:       mac
50
Requires:       shntool
51
Requires:       ttaenc
52
Requires:       vorbis-tools
53
Requires:       wavpack
54
Recommends:     %{name}-lang
55
Recommends:     mp3gain
56
Recommends:     vorbisgain
57
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
58
59
%description
60
Flacon extracts individual tracks from one big audio file containing
61
the entire album of music and saves them as separate audio files. To do
62
this, it uses information from the appropriate CUE file. Besides, Flacon
63
makes it possible to conveniently revise or specify tags both for all
64
tracks at once or for each tag separately.
65
66
%lang_package
67
68
%prep
69
%setup -q
70
%patch0 -p1
71
72
%build
73
mkdir build
74
cd build
75
cmake .. \
76
    -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77
    -DCMAKE_C_FLAGS="%{optflags}" \
78
    -DCMAKE_CXX_FLAGS="%{optflags}"
79
make %{?_smp_mflags} VERBOSE=1
80
81
%install
82
pushd build
83
%make_install
84
popd
85
%find_lang %{name} --with-qt
86
%suse_update_desktop_file %{name}
87
88
%post
89
%desktop_database_post
90
%icon_theme_cache_post
91
92
%postun
93
%desktop_database_postun
94
%icon_theme_cache_postun
95
96
%files
97
%defattr(-,root,root,-)
98
%doc LICENSE README.md
99
%{_bindir}/%{name}
100
%{_datadir}/%{name}/
101
%exclude %{_datadir}/%{name}/translations/
102
%{_datadir}/applications/%{name}.desktop
103
%{_datadir}/icons/hicolor/*/*/%{name}.*
104
%doc %{_mandir}/man?/*
105
106
%files lang -f %{name}.lang
107
%defattr(-,root,root,-)
108
%dir %{_datadir}/%{name}/translations/
109
110
%changelog
111