File flowblade.spec of Package flowblade (Revision b42f702489762cac48f88e61eeb06157)
Currently displaying revision b42f702489762cac48f88e61eeb06157 , Show latest
127
1
#
2
# spec file for package flowblade
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: flowblade
20
Version: 1.16
21
Release: 0
22
Summary: Multitrack non-linear video editor
23
License: GPL-3.0-only
24
Group: Productivity/Multimedia/Video/Editors and Convertors
25
URL: http://jliljebl.github.io/flowblade
26
Source: https://github.com/jliljebl/flowblade/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
27
BuildRequires: fdupes
28
BuildRequires: frei0r-plugins >= 1.4
29
BuildRequires: gobject-introspection
30
BuildRequires: python-devel >= 2.7.0
31
BuildRequires: shared-mime-info
32
BuildRequires: update-desktop-files
33
Requires: dbus-1-python
34
Requires: ffmpeg
35
Requires: frei0r-plugins >= 1.4
36
Requires: ladspa
37
Requires: ladspa-swh-plugins
38
Requires: libmlt6-data
39
Requires: libmlt6-modules
40
Requires: python-cairo
41
Requires: python-gobject
42
Requires: python-gobject-Gdk
43
Requires: python-imaging
44
Requires: python-mlt
45
Requires: python-numpy
46
Requires: rsvg-view
47
Requires: sox
48
Recommends: gmic
49
BuildArch: noarch
50
# SECTION Check dependencies:
51
BuildRequires: dbus-1-python
52
BuildRequires: libmlt6-modules >= 6.6.0
53
BuildRequires: python-cairo
54
BuildRequires: python-imaging
55
BuildRequires: python-mlt
56
BuildRequires: python-numpy
57
BuildRequires: rsvg-view
58
# / SECTION
59
60
%description
61
Flowblade is designed to provide a fast, precise and robust editing experience.
62
63
In Flowblade clips are usually automatically placed tightly after or between
64
clips when they are inserted on the timeline. Edits are fine tuned by trimming
65
in and out points of clips, or by cutting and deleting parts of clips.
66
67
Flowblade provides powerful tools to mix and filter video and audio.
68
69
%lang_package
70
71
%prep
72
%setup -q -n %{name}-%{version}/%{name}-trunk
73
74
# Check MLT build with SDL 1.2
75
rpm -qR libmlt6-modules | grep -w libSDL || 'SDL 1.2 not found' 2> /dev/null
76
#
77
sed -i 's|%{_datadir}/pyshared|%{python_sitelib}|' %{name}
78
79
%build
80
python setup.py build
81
82
%install
83
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
84
85
mkdir -p %{buildroot}%{_datadir}/locale
86
mv %{buildroot}{%{python_sitelib}/Flowblade/locale/*,%{_datadir}/locale/}
87
find %{buildroot} -type f -name "*.po*" -delete -print
88
89
rm -rf %{buildroot}%{_libexecdir}/mime/packages/%{name}
90
91
%fdupes %{buildroot}%{python_sitelib}
92
%find_lang %{name}
93
94
# Fix: non-executable-script
95
pushd %{buildroot}
96
for _file in $(grep -rl '^\#\!\/'); do
97
! echo $_file | grep '\/usr\/bin\|\/launch' || chmod 0755 $_file
98
find -name ${_file##*/} -type f -perm 644 -exec sed '/^\#\!/d' -i {} \+
99
find -name ${_file##*/} -type f -perm 755 -exec sed '/^\#\!\/.\+py/c\#\!%{_bindir}/python' -i {} \+
100
find -name ${_file##*/} -type f -perm 755 -exec sed '/^\#\!\/.\+sh/c\#\!/bin/bash' -i {} \+
101
done
102
%py_compile .%{python_sitelib}
103
popd
104
105
%post
106
%mime_database_post
107
%desktop_database_post
108
109
%postun
110
%mime_database_postun
111
%desktop_database_postun
112
113
%files
114
%license COPYING
115
%doc AUTHORS README docs/RELEASE_NOTES*
116
%{_bindir}/%{name}
117
%{_datadir}/applications/%{name}.desktop
118
%{_datadir}/pixmaps/%{name}.??g
119
%{_datadir}/mime/packages/%{name}.xml
120
%{_mandir}/man?/%{name}.?%{ext_info}
121
%{python_sitelib}/Flowblade/
122
%{python_sitelib}/%{name}*info
123
124
%files lang -f %{name}.lang
125
126
%changelog
127