File flowblade.spec of Package flowblade (Revision 10)

Currently displaying revision 10 , Show latest

95
 
1
#
2
# spec file for package flowblade
3
#
4
# Copyright (c) 2025 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name:           flowblade
20
Version:        2.18.1
21
Release:        0
22
Summary:        Multitrack non-linear video editor
23
License:        GPL-3.0-only
24
Group:          Productivity/Multimedia/Video/Editors and Convertors
25
URL:            http://jliljebl.github.io/flowblade
26
Source0:        %name-%version.tar
27
BuildArch:      noarch
28
BuildRequires:  fdupes
29
BuildRequires:  pkgconfig(python3)
30
BuildRequires:  python-rpm-macros
31
BuildRequires:  python3-setuptools
32
Requires:       ffmpeg
33
Requires:       frei0r-plugins
34
Requires:       ladspa
35
Requires:       ladspa-swh-plugins
36
Requires:       libmlt7-data
37
Requires:       libmlt7-modules
38
Requires:       python3-Pillow
39
Requires:       python3-cairo
40
Requires:       python3-gobject
41
Requires:       python3-gobject-Gdk
42
Requires:       python3-libusb1
43
Requires:       python3-mlt
44
Requires:       python3-numpy
45
Requires:       rsvg-view
46
Requires:       sox
47
48
%description
49
Flowblade is designed to provide a fast, precise and robust editing experience.
50
51
In Flowblade clips are usually automatically placed tightly after or between
52
clips when they are inserted on the timeline. Edits are fine tuned by trimming
53
in and out points of clips, or by cutting and deleting parts of clips.
54
55
Flowblade provides powerful tools to mix and filter video and audio.
56
57
%lang_package
58
59
%prep
60
%autosetup -p1
61
62
%build
63
pushd flowblade-trunk
64
sed -i~ 's|%_datadir/pyshared|%python_sitelib|' %name
65
diff -u "$_"~ "$_" && exit 1
66
%python3_build
67
popd
68
69
%install
70
pushd flowblade-trunk
71
%python3_install
72
mkdir -p %buildroot%_datadir/locale
73
mv %buildroot{%python_sitelib/Flowblade/locale/*,%_datadir/locale/}
74
find %buildroot -type f -name "*.po*" -delete -print
75
rm -rfv %buildroot%_prefix/lib/mime
76
popd
77
%fdupes %buildroot%python_sitelib
78
%find_lang %name
79
80
%files
81
%license LICENSE
82
%doc flowblade-trunk/docs/RELEASE_NOTES.md
83
%_bindir/*
84
%_datadir/applications/*.desktop
85
%_datadir/icons/*
86
%_datadir/metainfo/*.xml
87
%_datadir/mime/packages/*.xml
88
%_mandir/man?/*
89
%python_sitelib/Flowblade/
90
%python_sitelib/%name-*-info
91
92
%files lang -f %name.lang
93
94
%changelog
95