File flowblade.spec of Package flowblade (Revision 12)

Currently displaying revision 12 , Show latest

94
 
1
#
2
# spec file for package flowblade
3
#
4
# Copyright (c) 2025 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name:           flowblade
20
Version:        2.20
21
Release:        0
22
Summary:        Multitrack non-linear video editor
23
License:        GPL-3.0-only
24
Group:          Productivity/Multimedia/Video/Editors and Convertors
25
URL:            http://jliljebl.github.io/flowblade
26
Source0:        %name-%version.tar
27
BuildArch:      noarch
28
BuildRequires:  fdupes
29
BuildRequires:  pkgconfig(python3)
30
BuildRequires:  python-rpm-macros
31
BuildRequires:  python3-setuptools
32
Requires:       ffmpeg
33
Requires:       frei0r-plugins
34
Requires:       ladspa
35
Requires:       ladspa-swh-plugins
36
Requires:       libmlt7-data
37
Requires:       libmlt7-modules
38
Requires:       python3-Pillow
39
Requires:       python3-cairo
40
Requires:       python3-gobject
41
Requires:       python3-gobject-Gdk
42
Requires:       python3-libusb1
43
Requires:       python3-mlt
44
Requires:       python3-numpy
45
Requires:       sox
46
47
%description
48
Flowblade is designed to provide a fast, precise and robust editing experience.
49
50
In Flowblade clips are usually automatically placed tightly after or between
51
clips when they are inserted on the timeline. Edits are fine tuned by trimming
52
in and out points of clips, or by cutting and deleting parts of clips.
53
54
Flowblade provides powerful tools to mix and filter video and audio.
55
56
%lang_package
57
58
%prep
59
%autosetup -p1
60
61
%build
62
pushd flowblade-trunk
63
sed -i~ 's|%_datadir/pyshared|%python3_sitelib|' %name
64
diff -u "$_"~ "$_" && exit 1
65
%python3_build
66
popd
67
68
%install
69
pushd flowblade-trunk
70
%python3_install
71
mkdir -p %buildroot%_datadir/locale
72
mv %buildroot{%python3_sitelib/Flowblade/locale/*,%_datadir/locale/}
73
find %buildroot -type f -name "*.po*" -delete -print
74
rm -rfv %buildroot%_prefix/lib/mime
75
popd
76
%fdupes %buildroot%python3_sitelib
77
%find_lang %name
78
79
%files
80
%license LICENSE
81
%doc flowblade-trunk/docs/RELEASE_NOTES.md
82
%_bindir/*
83
%_datadir/applications/*.desktop
84
%_datadir/icons/*
85
%_datadir/metainfo/*.xml
86
%_datadir/mime/packages/*.xml
87
%_mandir/man?/*
88
%python3_sitelib/Flowblade/
89
%python3_sitelib/%name-*-info
90
91
%files lang -f %name.lang
92
93
%changelog
94