File flowblade.spec of Package flowblade (Revision 4)
Currently displaying revision 4 , Show latest
116
1
#
2
# spec file for package flowblade
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
%define prjname Flowblade
19
Name: flowblade
20
Version: 1.10
21
Release: 0
22
Summary: Multitrack non-linear video editor
23
License: GPL-3.0
24
Group: Productivity/Multimedia/Video/Editors and Convertors
25
Url: https://code.google.com/p/flowblade/
26
Source: https://github.com/jliljebl/flowblade/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
27
BuildRequires: python-devel >= 2.7.0
28
BuildRequires: update-desktop-files
29
BuildRequires: shared-mime-info
30
BuildRequires: fdupes
31
BuildRequires: frei0r-plugins >= 1.4
32
# Check list of dependencies:
33
BuildRequires: pkgconfig(cairomm-1.0)
34
BuildRequires: pkgconfig(librsvg-2.0)
35
BuildRequires: libmlt6-modules
36
BuildRequires: dbus-1-python
37
BuildRequires: python-cairo
38
BuildRequires: python-gnomevfs
39
BuildRequires: python-gobject
40
BuildRequires: python-imaging
41
BuildRequires: python-mlt
42
BuildRequires: python-numpy
43
Requires: dbus-1-python
44
Requires: ffmpeg
45
Requires: frei0r-plugins >= 1.4
46
Requires: ladspa
47
Requires: ladspa-swh-plugins
48
Requires: libmlt6-modules
49
Requires: python-cairo
50
Requires: python-gnomevfs
51
Requires: python-gobject
52
Requires: python-imaging
53
Requires: python-mlt
54
Requires: python-numpy
55
Requires: sox
56
Requires: %(rpm -qf $(readlink -qne %{_libdir}/libcairomm-1.0.so) --qf '%{NAME} >= %{VERSION}')
57
Requires: %(rpm -qf $(readlink -qne %{_libdir}/librsvg-2.so) --qf '%{NAME} >= %{VERSION}')
58
BuildRoot: %{_tmppath}/%{name}-%{version}-build
59
BuildArch: noarch
60
61
%description
62
Flowblade is designed to provide a fast, precise and robust editing experience.
63
64
In Flowblade clips are usually automatically placed tightly after or between
65
clips when they are inserted on the timeline. Edits are fine tuned by trimming
66
in and out points of clips, or by cutting and deleting parts of clips.
67
68
Flowblade provides powerful tools to mix and filter video and audio.
69
70
%lang_package
71
72
%prep
73
%setup -q -n %{name}-%{version}/%{name}-trunk
74
75
sed -i 's|%{_datadir}/pyshared|%{python_sitelib}|' %{name}
76
77
%build
78
python setup.py build
79
80
%install
81
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
82
83
mkdir -p %{buildroot}%{_datadir}/locale
84
mv %{buildroot}{%{python_sitelib}/%{prjname}/locale/*,%{_datadir}/locale/}
85
find %{buildroot} -type f -name "*.po*" -delete -print
86
87
rm -rf %{buildroot}%{_libexecdir}/mime/packages/%{name}
88
89
%fdupes -s %{buildroot}%{python_sitelib}
90
%find_lang %{name} %{name}.lang
91
92
%post
93
%mime_database_post
94
%desktop_database_post
95
96
%postun
97
%mime_database_postun
98
%desktop_database_postun
99
100
%files
101
%defattr(0644,root,root)
102
%doc AUTHORS COPYING README docs/RELEASE_NOTES*
103
%attr(0755,root,root) %{_bindir}/%{name}
104
%{_datadir}/applications/%{name}.desktop
105
%{_mandir}/man?/%{name}.?%{ext_info}
106
%{_datadir}/pixmaps/%{name}.png
107
%{_datadir}/mime/packages/%{name}.xml
108
%{python_sitelib}/%{prjname}
109
%attr(0755,root,root) %{python_sitelib}/%{prjname}/launch/%{name}*
110
%{python_sitelib}/%{name}-*.egg-info
111
112
%files lang -f %{name}.lang
113
%defattr(0644,root,root)
114
115
%changelog
116