File kodi.binary-addons-noX-raspberry-pi2.spec of Package kodi.binary-addons (Revision ed026bc6e72037883acd0f3d2ab29d90)
Currently displaying revision ed026bc6e72037883acd0f3d2ab29d90 , Show latest
171
1
#
2
# spec file for package kodi
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
# Please edit kodi.spec and kodi.changes only. *-noX.* files are generated from
20
# kodi.* files with the pre_checkin.sh script
21
%define kodi_version Jarvis
22
%define _kodi_addons_dir %{_datadir}/kodi/addons
23
# kodi can be built without X support when openGL ES is used (mainly used on ARM boards used as media center)
24
%define noX_build 1
25
%if %{noX_build}
26
# no X build needs openGL ES
27
%bcond_with enable_opengl
28
%bcond_without enable_opengles
29
%else
30
%ifarch %arm armv6l armv6hl
31
%bcond_with enable_opengl
32
%bcond_without enable_opengles
33
%else
34
%bcond_without enable_opengl
35
%bcond_with enable_opengles
36
%endif
37
%endif
38
39
%define kodi_platform raspberry-pi2
40
%define kodi_player omxplayer
41
42
Name: kodi.binary-addons-noX-raspberry-pi2
43
Version: 16.0
44
Release: 0
45
Summary: Binary Addons for Kodi
46
License: GPL-2.0+ and GPL-3.0+
47
Group: Productivity/Multimedia/Video/Players
48
Url: http://kodi.tv/
49
Source0: https://github.com/xbmc/xbmc/archive/%{version}-%{kodi_version}.tar.gz
50
Source1: kodi.binary-addons.spec.packages.inc
51
Source2: kodi.binary-addons.spec.files.inc
52
Source3: kodi.binary-addons.tar
53
Source4: repo-binary-addons.%{kodi_version}.tar.bz2
54
Source5: kodi-platform-15edaf7.tar.gz
55
Patch1: cmake-binary-addons.patch
56
Patch2: addon-helpers_lib64.patch
57
58
BuildRequires: autoconf
59
BuildRequires: automake
60
BuildRequires: ccache
61
BuildRequires: cmake
62
BuildRequires: fdupes
63
BuildRequires: gcc-c++
64
BuildRequires: jsoncpp-devel
65
BuildRequires: kodi-devel
66
BuildRequires: tinyxml-devel
67
BuildRequires: libmp3lame-devel
68
BuildRequires: libSOIL-devel
69
BuildRequires: libtool
70
BuildRequires: pkg-config
71
BuildRequires: pkgconfig(fluidsynth)
72
BuildRequires: pkgconfig(flac)
73
BuildRequires: pkgconfig(libhdhomerun)
74
BuildRequires: pkgconfig(libmodplug)
75
BuildRequires: pkgconfig(libpng)
76
BuildRequires: pkgconfig(libprojectM)
77
BuildRequires: pkgconfig(platform)
78
BuildRequires: pkgconfig(tinyxml2)
79
BuildRequires: pkgconfig(vorbis)
80
81
# kodi needs the same libtag version which was used to build against
82
%requires_eq libtag1
83
%if !%{noX_build}
84
BuildRequires: xorg-x11-devel
85
%endif
86
%if %{with enable_opengl}
87
BuildRequires: pkgconfig(gl)
88
BuildRequires: pkgconfig(glew)
89
BuildRequires: pkgconfig(glu)
90
BuildRequires: pkgconfig(vdpau)
91
%endif
92
93
%if %{with enable_opengles}
94
%if %{kodi_platform} == "none"
95
BuildRequires: Mesa-libEGL-devel
96
BuildRequires: Mesa-libGLESv2-devel
97
%else
98
%if %{kodi_platform} == "raspberry-pi" || %{kodi_platform} == "raspberry-pi2"
99
BuildRequires: raspberrypi-userland-devel
100
%endif
101
%endif
102
%endif
103
104
# glxinfo is needed to check hw accel
105
%if 0%{?suse_version} >= 1220
106
%if !%{noX_build}
107
Requires: Mesa-demo-x
108
Requires: xdpyinfo
109
%endif
110
%endif
111
112
BuildRoot: %{_tmppath}/%{name}-%{version}-build
113
ExcludeArch: ppc64
114
Requires: kodi = %{version}
115
Requires: libjsoncpp1
116
117
%description
118
Binary Addons for Kodi Media Center
119
120
%include %{SOURCE1}
121
122
%prep
123
%setup -q -n xbmc-%{version}-%{kodi_version}
124
%patch1
125
%ifarch x86_64
126
%patch2
127
%endif
128
129
pushd project/cmake/addons
130
tar xvf %{SOURCE3}
131
mkdir -pv build/bootstrap/binary-addons/src
132
cp -v %{SOURCE4} build/bootstrap/binary-addons/src
133
134
#remove deps that are already installed using BuildRequires
135
rm -rf depends/common/{platform,tinyxml}
136
rm -f depends/common/kodi-platform/deps.txt
137
tar xf %{SOURCE5} --strip-components=1 -C depends/common/kodi-platform
138
echo "kodi-platform file://../depends/common/kodi-platform" > depends/common/kodi-platform/kodi-platform.txt
139
popd
140
141
%build
142
pushd project/cmake/addons
143
%cmake \
144
%ifarch i586
145
-DCMAKE_C_FLAGS='-msse' \
146
%endif
147
-DBUILD_DIR=build \
148
-DBUILD_SHARED_LIBS=1 \
149
-DNEED_SUDO=FALSE \
150
-DAPP_LIB_DIR=%{buildroot}%{_libdir}/kodi/ \
151
-DCMAKE_INSTALL_LIBDIR=%{buildroot}%{_libdir}/kodi/ \
152
-DCMAKE_INSTALL_PREFIX=%{buildroot}%{_prefix}
153
make VERBOSE=1 %{?_smp_mflags}
154
popd
155
156
%install
157
#make DESTDIR=%{buildroot} install %{?_smp_mflags}
158
159
%fdupes %{buildroot}
160
161
%files
162
%defattr(-,root,root)
163
%dir %{_libdir}/kodi
164
%dir %{_datadir}/kodi
165
%{_libdir}/kodi/prepare-env.cmake
166
167
168
%include %{SOURCE2}
169
170
%changelog
171