File nordlicht.spec of Package nordlicht (Revision ff0ed9a2db7228a80725af6b7019bd47)

Currently displaying revision ff0ed9a2db7228a80725af6b7019bd47 , Show latest

89
 
1
%define soname 0
2
3
Name:           nordlicht
4
Version:        0.3.5
5
Release:        0
6
License:        GPL-2.0+
7
Summary:        Creates colorful barcodes from video files
8
Url:            https://github.com/nordlicht/%{name}
9
Group:          Productivity/Multimedia/Editors and Convertors
10
Source0:        https://github.com/nordlicht/%{name}/archive/v%{version}.tar.gz
11
Patch0:         nordlicht-ffmpeg-deps.patch
12
13
BuildRequires:  cmake
14
BuildRequires:  help2man
15
BuildRequires:  libpng-devel
16
BuildRequires:  pkg-config
17
BuildRequires:  pkgconfig(libavcodec)
18
BuildRequires:  pkgconfig(libavformat)
19
BuildRequires:  pkgconfig(libswscale)
20
BuildRequires:  popt-devel
21
22
ExcludeArch:    %arm
23
24
%description
25
C library for converting video files into colorful
26
barcodes. It is inspired by the Moviebarcode Tumblr, but
27
aims at the next logical step: Integrating these barcodes
28
into video players to make navigation faster and more
29
precise.
30
31
This package provides a command line tool, which you can
32
use to generate your own barcodes easily.
33
34
%package -n lib%{name}%{soname}
35
Summary:        Creates colorful barcodes from video files
36
Group:          System/Libraries
37
38
%description -n lib%{name}%{soname}
39
C library for converting video files into colorful
40
barcodes. It is inspired by the Moviebarcode Tumblr, but
41
aims at the next logical step: Integrating these barcodes
42
into video players to make navigation faster and more
43
precise.
44
45
%package devel
46
Summary:        Development files for nordlicht
47
Group:          Development/Libraries/C and C++
48
Requires:       lib%{name}%{soname} >= %{version}
49
Provides:       pkgconfig(nordlicht)
50
51
%description devel
52
This package contains all necessary include files and
53
libraries needed to compile and develop applications that
54
use nordlicht.
55
56
%prep
57
%setup -q
58
%patch0 -p1
59
60
%build
61
cmake . \
62
    -DCMAKE_C_FLAGS:STRING="%{optflags}" \
63
    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
64
    -DLIB_INSTALL_DIR:PATH=%{_libdir}
65
make %{?_smp_mflags}
66
67
%install
68
%make_install
69
70
%post -n lib%{name}%{soname} -p /sbin/ldconfig
71
%postun -n lib%{name}%{soname} -p /sbin/ldconfig
72
73
%files
74
%defattr(-,root,root)
75
%doc %{_mandir}/man1/%{name}.1%{ext_man}
76
%{_bindir}/%{name}
77
78
%files -n lib%{name}%{soname}
79
%defattr(-,root,root)
80
%{_libdir}/lib%{name}.so.%{soname}
81
82
%files devel
83
%defattr(-,root,root)
84
%{_libdir}/lib%{name}.so
85
%{_libdir}/pkgconfig/%{name}.pc
86
%{_includedir}/%{name}.h
87
88
%changelog
89