File obs-studio.spec of Package obs-studio (Revision 9)

Currently displaying revision 9 , Show latest

90
 
1
Name:           obs-studio
2
Version:        0.9.0+git20150325.1ab1a97
3
Release:        0
4
Summary:        A recording/broadcasting program
5
6
Group:          Multimedia
7
License:        GPL-2.0
8
URL:            https://obsproject.com/
9
Source:         %{name}-%{version}.tar.xz
10
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-build
11
12
BuildRequires:  cmake
13
BuildRequires:  fontconfig-devel
14
BuildRequires:  freetype2-devel
15
BuildRequires:  gcc
16
BuildRequires:  gcc-c++
17
BuildRequires:  hicolor-icon-theme
18
BuildRequires:  libffmpeg-devel
19
BuildRequires:  libjansson-devel
20
BuildRequires:  libpulse-devel 
21
BuildRequires:  libqt5-qtbase-devel
22
BuildRequires:  libqt5-qtx11extras-devel
23
BuildRequires:  libudev-devel
24
BuildRequires:  libv4l-devel
25
BuildRequires:  libXcomposite-devel
26
BuildRequires:  libXinerama-devel
27
BuildRequires:  libXrandr-devel
28
29
%description
30
Open Broadcaster Software is free and open source software for video recording and live streaming.
31
32
%package devel
33
Summary:        A recording/broadcasting program - Development Files
34
Group:          Development/Multimedia
35
Requires:       %{name} = %{version}
36
37
%description devel
38
Open Broadcaster Software is free and open source software for video recording and live streaming.
39
40
%prep
41
%setup -q
42
43
%build
44
mkdir -p build && cd build
45
# does not like cmake macro as it fails to link in math.h (-lm)
46
cmake \
47
  -DUNIX_STRUCTURE=1 \
48
  -DCMAKE_INSTALL_PREFIX=/usr \
49
  -DOBS_VERSION_OVERRIDE="%{version}" \
50
  ..
51
52
%install
53
cd build
54
%make_install
55
56
# fix lib package locations which are inconsistent since they are 64bit libs, but placed in lib/
57
%ifarch x86_64
58
mkdir -p %{buildroot}%{_libdir}/obs-plugins
59
# needs obs-plugins in lib/ even though 64bit
60
# mv %%{buildroot}/usr/lib/obs-plugins/* %%{buildroot}%%{_libdir}/obs-plugins
61
mv %{buildroot}/usr/lib/libobs*.so* %{buildroot}%{_libdir}
62
%endif
63
64
%post   -n %{name} -p /sbin/ldconfig
65
%postun -n %{name} -p /sbin/ldconfig
66
67
%clean
68
rm -rf %{buildroot}
69
70
%files
71
%defattr(-, root, root)
72
%{_bindir}/obs
73
# needs obs-plugins in lib/ even though 64bit
74
%{_usr}/lib/obs-plugins
75
%{_libdir}/libobs.so.0
76
%{_libdir}/libobs-opengl.so*
77
%{_libdir}/libobsglad.so.0
78
%{_datadir}/applications/obs.desktop
79
%{_datadir}/icons/hicolor/256x256/apps/obs.png
80
%{_datadir}/obs
81
82
%files devel
83
%defattr(-, root, root)
84
%{_usr}/lib/cmake
85
%{_libdir}/libobs.so
86
%{_libdir}/libobsglad.so
87
%{_includedir}/obs
88
89
%changelog
90