File shoutsend.spec of Package shoutsend

44
 
1
# vim: set sw=4 ts=4 et nu:
2
3
# Copyright (c) 2013 Pascal Bleser <pascal.bleser@opensuse.org>
4
#
5
# All modifications and additions to the file contributed by third parties
6
# remain the property of their copyright owners, unless otherwise agreed
7
# upon. The license for this file, and modifications and additions to the
8
# file, is the same license as for the pristine package itself (unless the
9
# license for the pristine package is not an Open Source License, in which
10
# case the license is the MIT License). An "Open Source License" is a
11
# license that conforms to the Open Source Definition (Version 1.9)
12
# published by the Open Source Initiative.
13
14
Name:               shoutsend
15
Version:            1.02
16
Release:            0.pm.1
17
Summary:            Simple Streaming Source Client for ShoutCast/IceCast
18
Source:             shoutsend-%version.tar.gz
19
Patch1:             shoutsend-fix_includes.patch
20
URL:                http://sokrates.mimuw.edu.pl/~sebek/shoutsend/
21
License:            GPL-2.0+
22
BuildRequires:      pkgconfig(shout)
23
24
%description
25
ShoutSend is a simple streaming client for ShoutCast/IceCast servers. It takes
26
audio data stream from stdin (in mp3 or ogg format) and without any processing
27
sends it along with some metadata (like stream description) to streaming
28
server.
29
30
%prep
31
%autosetup -p1
32
33
%build
34
cc %optflags -o shoutsend shoutsend.c $(pkg-config --cflags --libs shout)
35
36
%install
37
install -D -m0755 shoutsend "%buildroot%_bindir/shoutsend"
38
39
%files
40
%doc README.txt
41
%_bindir/shoutsend
42
43
%changelog
44