File shoutsend.spec of Package shoutsend (Revision 2)

Currently displaying revision 2 , Show latest

54
 
1
# vim: set sw=4 ts=4 et nu:
2
3
# Copyright (c) 2013 Pascal Bleser <pascal.bleser@opensuse.org>
4
#
5
# All modifications and additions to the file contributed by third parties
6
# remain the property of their copyright owners, unless otherwise agreed
7
# upon. The license for this file, and modifications and additions to the
8
# file, is the same license as for the pristine package itself (unless the
9
# license for the pristine package is not an Open Source License, in which
10
# case the license is the MIT License). An "Open Source License" is a
11
# license that conforms to the Open Source Definition (Version 1.9)
12
# published by the Open Source Initiative.
13
14
# Please submit bugfixes or comments via http://bugs.opensuse.org/
15
16
Name:               shoutsend
17
Version:            1.02
18
Release:            0.pm.1
19
Summary:            Simple Streaming Source Client for ShoutCast/IceCast
20
Source:             http://sokrates.mimuw.edu.pl/~sebek/shoutsend/shoutsend-%{version}.tar.gz
21
Patch1:             shoutsend-fix_includes.patch
22
URL:                http://sokrates.mimuw.edu.pl/~sebek/shoutsend/
23
Group:              Productivity/Multimedia/Sound/Utilities
24
License:            GPL-2.0+
25
BuildRoot:          %{_tmppath}/build-%{name}-%{version}
26
BuildRequires:      libshout-devel
27
BuildRequires:      gcc make glibc-devel pkgconfig
28
29
%description
30
ShoutSend is a simple streaming client for ShoutCast/IceCast servers. It takes
31
audio data stream from stdin (in mp3 or ogg format) and without any processing
32
sends it along with some metadata (like stream description) to streaming
33
server.
34
35
%prep
36
%setup -q
37
%patch -P 1
38
39
%build
40
%__cc -o shoutsend shoutsend.c -lshout -lpthread
41
42
%install
43
%__install -D -m0755 shoutsend "%{buildroot}%{_bindir}/shoutsend"
44
45
%clean
46
%{?buildroot:%__rm -rf "%{buildroot}"}
47
48
%files
49
%defattr(-,root,root)
50
%doc README.txt
51
%{_bindir}/shoutsend
52
53
%changelog
54