File vobcopy.spec of Package vobcopy
62
1
# vim: set sw=4 ts=4 et:
2
3
Name: vobcopy
4
Summary: Vobcopy copies DVD .vob files to harddisk
5
Summary(de): Vobcopy kopiert DVD .vob Dateien auf die Festplatte
6
License: GPL-2.0+
7
Group: Productivity/Multimedia/Video/Editors and Convertors
8
URL: https://github.com/barak/vobcopy
9
Version: 1.2.1
10
Release: 2
11
Source0: https://github.com/barak/vobcopy/archive/refs/tags/%{version}.tar.gz#/vobcopy-%{version}.tar.gz
12
BuildRoot: %{_tmppath}/%{name}-root
13
BuildRequires: autoconf
14
BuildRequires: automake
15
BuildRequires: glibc-devel
16
BuildRequires: gcc
17
#BuildRequires: libdvdread3 >= 0.9.7
18
#BuildRequires: libdvdread3-devel >= 0.9.7
19
BuildRequires: libdvdread-devel >= 0.9.7
20
21
%description
22
vobcopy called without arguments will find the mounted dvd and copy the
23
title with the most chapters to the current working directory (thats the
24
directory you're invoking vobcopy from). It will merge together the
25
sub-vobs of each title-vob (vts_xx_yy.vob => the xx is the title-vob,
26
the yy and friends are the sub-vobs, mostly of 1 GB size) and copy them
27
to harddisk in 2 GB chunks. It will get the title of the movie from the
28
dvd and copy the data to name-of-moviexx-1.vob, name-of-moviexx-2.vob
29
(the xx being the title number). Also possible is to mirror the whole video
30
dvd content and single files can also be copied.
31
32
%prep
33
%setup -q
34
35
%build
36
export CFLAGS="${RPM_OPT_FLAGS}"
37
autoreconf -fi
38
./configure \
39
--prefix="%{_prefix}" \
40
--bindir="%{_bindir}" \
41
--mandir="%{_mandir}" \
42
--with-dvdread-libs="%{_prefix}" \
43
--with-lfs
44
45
%__make %{?_smp_flags}
46
47
%install
48
%makeinstall
49
%{__rm} -rf %{buildroot}%{_datadir}/doc
50
51
%clean
52
%{?buildroot:%__rm -rf "%{buildroot}"}
53
54
%files
55
%defattr(-, root, root)
56
%doc alternative_programs.txt Changelog COPYING README Release-Notes TODO
57
%{_bindir}/vobcopy
58
%doc %{_mandir}/man1/vobcopy.1%{ext_man}
59
%doc %{_mandir}/de/man1/vobcopy.1%{ext_man}
60
61
%changelog
62