File x265.spec of Package x265
169
1
#
2
# spec file for package x265
3
#
4
# Copyright (c) 2024 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2014 Torsten Gruner <t.gruner@katodev.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.links2linux.org/
17
#
18
19
20
%define sover 215
21
%define libname lib%name
22
%define libsoname %{libname}-%{sover}
23
%define uver 4_1
24
Name: x265
25
Version: 4.1
26
Release: 0
27
Summary: A free h265/HEVC encoder - encoder binary
28
License: GPL-2.0-or-later
29
URL: https://bitbucket.org/multicoreware/x265_git
30
Source0: %name-%version.tar
31
Patch0: %name.patch
32
Patch1: x265.pkgconfig.patch
33
Patch3: 0001-Fix-arm-flags.patch
34
Patch4: 0004-Do-not-build-with-assembly-support-on-arm.patch
35
BuildRequires: cmake
36
%if 0%{?suse_version} > 1500
37
BuildRequires: gcc-c++
38
%else
39
BuildRequires: gcc13
40
BuildRequires: gcc13-c++
41
%endif
42
BuildRequires: nasm >= 2.13
43
BuildRequires: pkgconfig
44
%ifarch x86_64
45
BuildRequires: libnuma-devel >= 2.0.9
46
%endif
47
48
%description
49
x265 is a free library for encoding next-generation H265/HEVC video
50
streams.
51
52
%package -n %{libsoname}
53
Summary: A free H265/HEVC encoder - encoder binary
54
55
%description -n %{libsoname}
56
x265 is a free library for encoding next-generation H265/HEVC video
57
streams.
58
59
%package -n libhdr10plus-%{uver}
60
Summary: A free HDR10+ library
61
62
%description -n libhdr10plus-%{uver}
63
A free library supporting HDR10+.
64
65
%package -n %{libname}-devel
66
Summary: Libraries and include file for the %{libname} encoder
67
Requires: %{libsoname} = %version-%release
68
Requires: libhdr10plus-%{uver} = %version-%release
69
Provides: %name-devel = %version
70
Obsoletes: %name-devel < %version
71
72
%description -n %{libname}-devel
73
x265 is a free library for encoding next-generation H265/HEVC video
74
streams.
75
76
%prep
77
%autosetup -p1
78
79
%build
80
test -x "$(type -p gcc)" && CC="$_"
81
test -x "$(type -p g++)" && CXX="$_"
82
test -x "$(type -p gcc-13)" && CC="$_"
83
test -x "$(type -p g++-13)" && CXX="$_"
84
export CC="$(readlink -f ${CC})"
85
export CXX="$(readlink -f ${CXX})"
86
CFLAGS='%optflags -Wno-misleading-indentation -Wno-unused-parameter -Wno-unused-variable'
87
CXXFLAGS='%optflags -Wno-misleading-indentation -Wno-unused-parameter -Wno-unused-variable'
88
# set the version by hand
89
sed -i~ "/^include(Version)/d" source/CMakeLists.txt
90
diff -u "$_"~ "$_" && exit 1
91
# force version number in the soname
92
sed -i~ 's/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus/hdr10plus-shared PROPERTIES OUTPUT_NAME hdr10plus-%version/' \
93
source/CMakeLists.txt
94
diff -u "$_"~ "$_" && exit 1
95
96
SOURCE_DIR="$PWD"/source
97
COMMON_FLAGS="-DENABLE_TESTS=OFF -DENABLE_PIC=ON -Wno-dev"
98
HIGH_BIT_DEPTH_FLAGS="-DENABLE_CLI=OFF -DENABLE_SHARED=OFF -DEXPORT_C_API=OFF -DHIGH_BIT_DEPTH=ON"
99
100
%define __sourcedir ./source
101
102
# Build 10bit depth version of the library
103
%define __builddir ./source/build-10bit
104
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS \
105
%ifarch i586
106
-DENABLE_ASSEMBLY=OFF
107
%endif
108
109
%make_build
110
cd ../..
111
112
# Build 12bit depth version of the library
113
%define __builddir ./source/build-12bit
114
%cmake $COMMON_FLAGS $HIGH_BIT_DEPTH_FLAGS -DMAIN12=ON \
115
%ifarch i586
116
-DENABLE_ASSEMBLY=OFF
117
%endif
118
119
%make_build
120
cd ../..
121
122
mv source/build-10bit/libx265.a source/build-10bit/libx265_main10.a
123
mv source/build-12bit/libx265.a source/build-12bit/libx265_main12.a
124
125
# Build general version of the library linking in the 10/12bit depth versions
126
%define __builddir ./source/build
127
%cmake $COMMON_FLAGS \
128
-DENABLE_SHARED=ON \
129
-DX265_LATEST_TAG="%{sover}.0" \
130
-DX265_VERSION="%version" \
131
-DENABLE_HDR10_PLUS=ON \
132
-DENABLE_CLI=ON \
133
-DLINKED_10BIT=ON \
134
-DLINKED_12BIT=ON \
135
-DEXTRA_LINK_FLAGS="-L$SOURCE_DIR/build-10bit -L$SOURCE_DIR/build-12bit" \
136
-DEXTRA_LIB="x265_main10.a;x265_main12.a"
137
%make_build
138
cd ../../
139
140
%install
141
%cmake_install
142
find %buildroot -type f -name "*.a" -delete -print0
143
144
%check
145
146
%post -n %{libsoname} -p /sbin/ldconfig
147
%postun -n %{libsoname} -p /sbin/ldconfig
148
149
%post -n libhdr10plus-%{uver} -p /sbin/ldconfig
150
%postun -n libhdr10plus-%{uver} -p /sbin/ldconfig
151
152
%files -n %{libsoname}
153
%doc doc/reST/releasenotes.rst
154
%_libdir/%{libname}.so.%{sover}*
155
156
%files -n libhdr10plus-%{uver}
157
%_libdir/libhdr10plus-%version.so
158
159
%files
160
%_bindir/*
161
162
%files -n %{libname}-devel
163
%license COPYING
164
%_includedir/*
165
%_libdir/pkgconfig/*.pc
166
%_libdir/%{libname}.so
167
168
%changelog
169