File libdisplay-info.spec of Package A_15.x-libdisplay-info
105
1
#
2
# spec file for package libdisplay-info
3
#
4
# Copyright (c) 2025 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name: libdisplay-info
20
%define lname libdisplay-info2
21
Version: 0.2.0
22
Release: 0
23
Summary: EDID and DisplayID library
24
License: MIT
25
Group: Development/Libraries/C and C++
26
URL: https://gitlab.freedesktop.org/emersion/libdisplay-info
27
Source: https://gitlab.freedesktop.org/emersion/libdisplay-info/-/releases/%version/downloads/libdisplay-info-%version.tar.xz
28
Source2: https://gitlab.freedesktop.org/emersion/libdisplay-info/-/releases/%version/downloads/libdisplay-info-%version.tar.xz.sig
29
Source3: %name.keyring
30
BuildRequires: c_compiler
31
BuildRequires: meson >= 0.57.0
32
BuildRequires: python3-base
33
BuildRequires: pkgconfig(hwdata)
34
BuildRequires: python3-base
35
36
%description
37
libdisplay-info is an EDID and DisplayID library. It provides a
38
low-level API exposing all of the details of these formats, plus a
39
high-level API (of opinionated functions) which abstracts these
40
details for common operations.
41
42
%package -n %lname
43
Summary: EDID and DisplayID library
44
Group: System/Libraries
45
46
%description -n %lname
47
libdisplay-info is an EDID and DisplayID library. It provides a
48
low-level API exposing all of the details of these formats, plus a
49
high-level API (of opinionated functions) which abstracts these
50
details for common operations.
51
52
%package tools
53
Summary: Command-line tools for %name
54
Requires: %lname = %version
55
Provides: %name-devel:%_bindir/di-edid-decode
56
57
%description tools
58
libdisplay-info is an EDID and DisplayID library. It provides a
59
low-level API exposing all of the details of these formats, plus a
60
high-level API (of opinionated functions) which abstracts these
61
details for common operations.
62
63
This package contains a tool to parse EDID.
64
65
%package devel
66
Summary: Header files for libdisplay-info, an EDID library
67
Group: Development/Libraries/C and C++
68
Requires: %lname = %version
69
70
%description devel
71
The library provides a set of low- and high-level functions
72
for EDID and DisplayID.
73
74
This package contains headers for the library.
75
76
%prep
77
%autosetup -p1
78
79
%build
80
# includedir intentional, cf. bugzilla.opensuse.org/795968
81
%meson --includedir="%_includedir/%name"
82
%meson_build
83
84
%install
85
%meson_install
86
87
%ldconfig_scriptlets -n %lname
88
89
%check
90
%meson_test
91
92
%files -n %lname
93
%_libdir/lib*.so.[0-9]*
94
95
%files tools
96
%_bindir/di-edid-decode
97
98
%files devel
99
%_includedir/%name/
100
%_libdir/pkgconfig/*.pc
101
%_libdir/*.so
102
%license LICENSE
103
104
%changelog
105