File obs-backgroundremoval.spec of Package obs-backgroundremoval (Revision 803df64c2f7674b9bae9b94f269a0072)
Currently displaying revision 803df64c2f7674b9bae9b94f269a0072 , Show latest
70
1
#
2
# spec file for package obs-backgroundremoval
3
#
4
# Copyright (c) 2023 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name: obs-backgroundremoval
20
Version: 1.1.5
21
Release: 0
22
Summary: OBS Plugin for Background Removal
23
License: GPL-2.0
24
URL: https://github.com/royshil/obs-backgroundremoval
25
Source: %{name}-%{version}.tar.gz
26
Source1: %{name}-rpmlintrc
27
Source2: opencv-linux-Release-4.8.0-1.tar.gz
28
Source3: onnxruntime-linux-x64-gpu-1.15.1.tgz
29
BuildRequires: cmake
30
BuildRequires: gcc-c++
31
BuildRequires: obs-studio
32
BuildRequires: curl
33
BuildRequires: cmake(libobs)
34
Requires: curl
35
Requires: obs-studio >= 29.0.0
36
ExclusiveArch: x86_64
37
38
%global __requires_exclude_from ^.*libonnxruntime.*$
39
40
%description
41
An OBS plugin for removing background in portrait images (video), making it easy to replace the background when screen recording.
42
43
%prep
44
%autosetup
45
46
%build
47
%cmake \
48
-DCUSTOM_OPENCV_URL=%{SOURCE2} \
49
-DCUSTOM_OPENCV_HASH=MD5=7a668fbc3ac536812643c6b8c8f96be9 \
50
-DCUSTOM_ONNXRUNTIME_URL=%{SOURCE3} \
51
-DCUSTOM_ONNXRUNTIME_MD5=8d2f5ee9f449bdecb10a45715fe74c53
52
%cmake_build
53
54
%install
55
%cmake_install
56
57
%post
58
%postun
59
60
%files
61
%license LICENSE
62
%doc README.md
63
%defattr(-,root,root,-)
64
/usr/lib64/obs-plugins/obs-backgroundremoval.so
65
/usr/lib64/obs-plugins/obs-backgroundremoval
66
/usr/share/obs/obs-plugins/obs-backgroundremoval
67
68
%changelog
69
70