File libdisplay-info.spec of Package A_15.x-libdisplay-info (Revision a07a0b73e727e2de32d4df1f6faafff3)
Currently displaying revision a07a0b73e727e2de32d4df1f6faafff3 , Show latest
104
1
#
2
# spec file for package libdisplay-info
3
#
4
# Copyright (c) 2025 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name: libdisplay-info
20
%define lname libdisplay-info2
21
Version: 0.2.0
22
Release: 0
23
Summary: EDID and DisplayID library
24
License: MIT
25
Group: Development/Libraries/C and C++
26
URL: https://gitlab.freedesktop.org/emersion/libdisplay-info
27
Source: https://gitlab.freedesktop.org/emersion/libdisplay-info/-/releases/%version/downloads/libdisplay-info-%version.tar.xz
28
Source2: https://gitlab.freedesktop.org/emersion/libdisplay-info/-/releases/%version/downloads/libdisplay-info-%version.tar.xz.sig
29
Source3: %name.keyring
30
BuildRequires: c_compiler
31
BuildRequires: meson >= 0.57.0
32
BuildRequires: python3-base
33
BuildRequires: pkgconfig(hwdata)
34
35
%description
36
libdisplay-info is an EDID and DisplayID library. It provides a
37
low-level API exposing all of the details of these formats, plus a
38
high-level API (of opinionated functions) which abstracts these
39
details for common operations.
40
41
%package -n %lname
42
Summary: EDID and DisplayID library
43
Group: System/Libraries
44
45
%description -n %lname
46
libdisplay-info is an EDID and DisplayID library. It provides a
47
low-level API exposing all of the details of these formats, plus a
48
high-level API (of opinionated functions) which abstracts these
49
details for common operations.
50
51
%package tools
52
Summary: Command-line tools for %name
53
Requires: %lname = %version
54
Provides: %name-devel:%_bindir/di-edid-decode
55
56
%description tools
57
libdisplay-info is an EDID and DisplayID library. It provides a
58
low-level API exposing all of the details of these formats, plus a
59
high-level API (of opinionated functions) which abstracts these
60
details for common operations.
61
62
This package contains a tool to parse EDID.
63
64
%package devel
65
Summary: Header files for libdisplay-info, an EDID library
66
Group: Development/Libraries/C and C++
67
Requires: %lname = %version
68
69
%description devel
70
The library provides a set of low- and high-level functions
71
for EDID and DisplayID.
72
73
This package contains headers for the library.
74
75
%prep
76
%autosetup -p1
77
78
%build
79
# includedir intentional, cf. bugzilla.opensuse.org/795968
80
%meson --includedir="%_includedir/%name"
81
%meson_build
82
83
%install
84
%meson_install
85
86
%ldconfig_scriptlets -n %lname
87
88
%check
89
%meson_test
90
91
%files -n %lname
92
%_libdir/lib*.so.[0-9]*
93
94
%files tools
95
%_bindir/di-edid-decode
96
97
%files devel
98
%_includedir/%name/
99
%_libdir/pkgconfig/*.pc
100
%_libdir/*.so
101
%license LICENSE
102
103
%changelog
104